app-admin/terraform: bump version to 0.12.11
authorDan Molik <dan@danmolik.com>
Fri, 4 Oct 2019 11:49:54 +0000 (07:49 -0400)
committerManuel Rüger <mrueg@gentoo.org>
Fri, 18 Oct 2019 14:23:59 +0000 (16:23 +0200)
Fix go vendoring
Fix licensing
Test with Go 1.12 and 1.13

Closes: https://bugs.gentoo.org/693766
Closes: https://bugs.gentoo.org/694720
Closes: https://bugs.gentoo.org/696738
Closes: https://github.com/gentoo/gentoo/pull/13130

Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Dan Molik <dan@danmolik.com>
Tested-by: Dan Molik <dan@danmolik.com>
Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
app-admin/terraform/Manifest
app-admin/terraform/terraform-0.12.11.ebuild [new file with mode: 0644]

index 8a72f8e1fb60d6463e6299e833f7cb5c0bf18ea6..9d2fbb52b1acaebd7975a3103ecdd7545396127b 100644 (file)
@@ -1,3 +1,4 @@
 DIST terraform-0.11.12.tar.gz 10907800 BLAKE2B d6d3c0a25b994be9b61e250a35adae55ed6cea0cc2166ea62774940292d9e881f16b66b88b19d5fd2c64d19bdefb82b58c79c54d8c641e1ad2970ef9a463c4c8 SHA512 2163cbc13a2bd37b7dace0a4ee2b3da4ee212038f9d6e11b83e509a794cf8d854040c366a099c9560a149157c6951b1f9d1698b4c47bd11a4fa96c4521e93414
 DIST terraform-0.11.13.tar.gz 10906645 BLAKE2B dafdc1acddd4ea97b41cc5899a541701731fce7b13b914c0859fe148b10b5c8ac877d71b665e8d80a65f376bb09fb8ae6fd0e0263ff711a156ca48119522f89d SHA512 1c16f20d1a65c763f1091ff2d20e0752e62903e07a12d41dd722e5c4c989f477da7d64901336d7536ed1693d5c82f4548ae5a643edae85b4e83325fc8c81b245
+DIST terraform-0.12.11.tar.gz 10338506 BLAKE2B 62c33591d55345e8c3b9c61b6f9279a81f1df86f5942cee787e4b525eefdf7834f0e4a6a42835b4ae038591fd467941454be674a3c1c8b329ef52c7d5e39359b SHA512 2b9fc6157aea8e7159d7089135620433d75843f2b3dd48af18ecb7837a5ca3ea72d9dfb8b36a25a65f9b9cc29b11bc7910f124a359a6589bfb941a714e0b7b23
 DIST terraform-0.12.3.tar.gz 9702723 BLAKE2B 90a6c77d1e1d6cac761572a470e23d44705fd0326ea9e2b280f51d9c95c85a74951ed93d8d8eed56821209bbd0725ffc034cf19bbb2da2baa390eafac790ac76 SHA512 49e1fefbfaf0dc0b0505836133c95dd5b664babfbdec094288ac823678cfb6e1593b19c9a0dca608cb1c7063f1ad531adba470c5ec67e3d245ef1e4341fd5b4a
diff --git a/app-admin/terraform/terraform-0.12.11.ebuild b/app-admin/terraform/terraform-0.12.11.ebuild
new file mode 100644 (file)
index 0000000..effc18e
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit golang-base go-module
+
+DESCRIPTION="A tool for building, changing, and combining infrastructure safely"
+HOMEPAGE="https://www.terraform.io/"
+
+EGO_PN="github.com/hashicorp/${PN}"
+SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD-2 BSD-4 ECL-2.0 imagemagick ISC JSON MIT MIT-with-advertising MPL-2.0 unicode"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+DEPEND=""
+
+DOCS=( {README,CHANGELOG}.md )
+
+src_compile() {
+       GOCACHE="${T}/go-cache" go build \
+               -work -o "bin/${PN}" ./ || die
+}
+
+src_install() {
+       dobin bin/terraform
+
+       einstalldocs
+}
+
+pkg_postinst() {
+       elog "If you would like to install shell completions please run:"
+       elog "    terraform -install-autocomplete"
+}