dev-libs/libvarlink: Bump to version 18
authorZac Medico <zmedico@gentoo.org>
Tue, 18 Feb 2020 20:11:57 +0000 (12:11 -0800)
committerZac Medico <zmedico@gentoo.org>
Tue, 18 Feb 2020 20:13:15 +0000 (12:13 -0800)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Zac Medico <zmedico@gentoo.org>
dev-libs/libvarlink/Manifest
dev-libs/libvarlink/libvarlink-18.ebuild [new file with mode: 0644]

index 8b15cd6b1c5a398c6b9ccf45db487cfc002c1b53..d0e3ff59dff46313ae5739f83f5cf3c45aa280f9 100644 (file)
@@ -1 +1,2 @@
 DIST libvarlink-16.tar.gz 56886 BLAKE2B 6c65199ced429eac733d1114cfad59c4514d299bd3bba0d4a9907498655545fd9edb9999428f39df936cd1e6710bacc08c04f05710e80f0ceb974b43809b9c22 SHA512 8152fc4fab4e9e829c2bc1585e479c23b0329c59da0be8712ff64dbbe01cde9630f228ac7edc06e9faa39dfd3d38007032ec6ed561e2363d4d33f65856f1a271
+DIST libvarlink-18.tar.gz 57708 BLAKE2B 035a3cad38d2429fa7a1bde049d6c5772ef10ef65040179839459d8672ef7fc619ff2a250ad48b108a9068c1f927226ad4ec08fa355b6c6f30a8ab8830422e9e SHA512 a0f2cfe6a3ce3e7c08b24436d4210691d6334ec903cb3d590627595ee3bda79bf4e22e7c72c7ea8ebe817e4e2b045f86d2603ae56b3fd7d429fd281fd7e5e2e8
diff --git a/dev-libs/libvarlink/libvarlink-18.ebuild b/dev-libs/libvarlink/libvarlink-18.ebuild
new file mode 100644 (file)
index 0000000..43b326c
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="C implementation of the Varlink protocol and command line tool"
+HOMEPAGE="https://github.com/varlink/libvarlink"
+SRC_URI="https://github.com/varlink/libvarlink/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND=""
+DEPEND="${RDEPEND}"
+BDEPEND="
+       >=dev-util/meson-0.47.0
+       virtual/pkgconfig
+"
+
+src_configure() {
+       local emesonargs=(
+               -Dtests="$(usex test true false)"
+       )
+       meson_src_configure
+}