dev-util/cmt: Respect environment CXXFLAGS and LDFLAGS.
authorBenda Xu <heroxbd@gentoo.org>
Mon, 16 Dec 2019 12:32:50 +0000 (20:32 +0800)
committerBenda Xu <heroxbd@gentoo.org>
Mon, 16 Dec 2019 14:04:15 +0000 (22:04 +0800)
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Benda Xu <heroxbd@gentoo.org>
dev-util/cmt/cmt-1.26_p20160527.ebuild
dev-util/cmt/files/cmt-1.26_p20160527-ldflags.patch [new file with mode: 0644]

index 71772dec6211ee1b1de429b719b9deb3ae9fb714..edf78928351c51c1213a0100bac2cb27e721d48b 100644 (file)
@@ -22,6 +22,8 @@ RDEPEND="${DEPEND}
 
 S="${WORKDIR}/CMT/${CMT_PV}"
 
+PATCHES=( "${FILESDIR}"/${PN}-1.26_p20160527-ldflags.patch )
+
 src_configure() {
        cd "${S}"/mgr || die
        ./INSTALL || die
diff --git a/dev-util/cmt/files/cmt-1.26_p20160527-ldflags.patch b/dev-util/cmt/files/cmt-1.26_p20160527-ldflags.patch
new file mode 100644 (file)
index 0000000..e249172
--- /dev/null
@@ -0,0 +1,29 @@
+--- a/mgr/requirements 2014-01-06 22:40:25.000000000 +0800
++++ b/mgr/requirements 2019-12-09 22:33:53.375723322 +0800
+@@ -157,7 +157,7 @@
+ macro cdebugflags     "" \
+       debug           "$(debug_option)"
+-macro cflags          "" \
++macro cflags          "${CFLAGS}" \
+       LynxOS-VGPW2    "-X" \
+       insure          "-std1" \
+       HP-UX           "+Z" \
+@@ -252,7 +252,7 @@
+       hp700_ux101     "-fpic" \
+       HP-UX           "+Z -Wc,-ansi_for_scope,on" \
+       hp_ux102        "-z +p -Wc,-ansi_for_scope,on +O2 +Onoinitcheck" \
+-      Linux           "-pipe -ansi -pedantic -W -Wall -Wwrite-strings -Wpointer-arith -Woverloaded-virtual " \
++      Linux           "${CXXFLAGS}" \
+       SunOS           "-KPIC" \
+       VisualC         '/nologo /DWIN32 /MD /W3 $(includes) /c /EHsc'
+@@ -403,7 +403,7 @@
+ macro shlibflags    "" \
+       HP-UX         "-Wl,-a,shared -b +Z -q -Wl,+s -Wl,+vallcompatwarnings" \
+       OSF1          "-shared -expect_unresolved '*'" \
+-      Linux         "-shared" \
++      Linux         "-shared ${LDFLAGS}" \
+       CYGWIN        "-shared" \
+       SunOS         "$(debug_option)" \
+       VisualC       "" \