sci-mathematics/gimps: bump to 28.7 (bug 557190)
authorThomas Kahle <tomka@gentoo.org>
Wed, 12 Aug 2015 07:28:51 +0000 (09:28 +0200)
committerThomas Kahle <tomka@gentoo.org>
Wed, 12 Aug 2015 07:28:51 +0000 (09:28 +0200)
Package-Manager: portage-2.2.20

sci-mathematics/gimps/Manifest
sci-mathematics/gimps/gimps-28.7.ebuild [new file with mode: 0644]

index 47f3c2419da0b460fd9b2846ad4dbd40607a23e8..d8697c7db1bf7511c7a83c2ac577a804a6b08e5a 100644 (file)
@@ -4,3 +4,5 @@ DIST p95v285.linux32.tar.gz 4608961 SHA256 534b7e5ab5e1574b51a2bb2928f057f91d375
 DIST p95v285.linux64.tar.gz 5658391 SHA256 185959f251f1c91591ced4436065e6837758e7d0fcce6cceaba04c4ba4161313 SHA512 1076fbec085fe18db665d538e54f1c7b6272aee5a9886f5a5c5528713435610c6c45a076cc9c40e2b7fcb72a83feb3b9051c6d78a00c623194668b0f023b0a80 WHIRLPOOL a792867121732fff818bf7be148f8da4d6386d2bc81d0b0cf0da639787a1f8cea04796e902c7df480f1f7a31f93c2e26710232a570ff3da07ecf09d25b47e259
 DIST p95v286.linux32.tar.gz 4610624 SHA256 dc4e90670c984e2e2628022b9e7347220e50e06f4d17c3bce21ffd743aeb26fb SHA512 fc78c06eea5850b84f4f8d62c042a0cac1280711a40a55c78cf31610acfeb55773098041c4bf93c2e89e7e2b32f37da4d9d714bfc69116cb3131fc3bf7137d2c WHIRLPOOL 4dab596cd6503df2370faaf111c32affe6cbdafa75b225c40f88c45856d9f33ec4b9072e115b69af3116c5679e77a8c528f13356abdd3f6b7c4c4db8a7f99391
 DIST p95v286.linux64.tar.gz 5661343 SHA256 50e86250e774ffb4120a17cf778411cac62a9ffa41e32ccf532f99eff3660f28 SHA512 b6fa3ff241feeca98dae7792d4912f491911a70a33ba243fac38ca43ba31fe1fddb6dea37670f082e6efa91abd24e0443143b031697d135cd270efa3d3998469 WHIRLPOOL 05dcd380528f1bc79303609174c65174e19f67b828245860b0516666b1b146331fb1148a007d1285be0dbd2e4ae73e53ced5dff5f59e37b524a9e3ab3176f87f
+DIST p95v287.linux32.tar.gz 4610011 SHA256 836ad76a17762dca50c2bed55c9e46655268e42b0de1c87e2499e92602e41435 SHA512 2f60c2801f02b6f72e71704f99f94512483da192d659fd691e3be2b562cdc4f174e744c276173b2b17b6c664be998d5b483e4aeda9e716afbc885e87cc919060 WHIRLPOOL c57f34beb0b46b6f5c822a63ae3281b70ca69167589d1b3b33c1e455da1f476cbfa8213c1053c2aedbc9f543cba7c3a1ac2d4ed2a98e7d6433be6ba2c47c32ed
+DIST p95v287.linux64.tar.gz 5661102 SHA256 3555426f170ae222de34599aca8dac9c621923a3e7d492d25138c086f45536ab SHA512 8e35af16bffe1e624f08797baa67d8890fd62a6b6ada1cbd1b4d37afb60e08f9f58dc8e566e0bc6e5e8fb714367e78c30dbff8b77c76a47d7b0935d10afd4c48 WHIRLPOOL 36ce137654d9a7a02643940349f0465d4a4592f4e35158b3d5512e2d5e24ea1f86105ec6cebff1369200ab45d8e5968c32d94ea2f747e666df444a4e13049d0e
diff --git a/sci-mathematics/gimps/gimps-28.7.ebuild b/sci-mathematics/gimps/gimps-28.7.ebuild
new file mode 100644 (file)
index 0000000..275b5b4
--- /dev/null
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit pax-utils systemd
+
+DESCRIPTION="The Great Internet Mersenne Prime Search"
+HOMEPAGE="http://mersenne.org/"
+SRC_URI="
+       amd64? ( ftp://mersenne.org/gimps/p95v${PV/./}.linux64.tar.gz )
+       x86? ( ftp://mersenne.org/gimps/p95v${PV/./}.linux32.tar.gz )"
+
+SLOT="0"
+LICENSE="GIMPS"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+# Since there are no statically linked binaries for this version of mprime,
+# and no static binaries for amd64 in general, we use the dynamically linked
+# ones and try to cover the .so deps with the packages listed in RDEPEND.
+DEPEND=""
+RDEPEND="net-misc/curl"
+
+S="${WORKDIR}"
+I="/opt/gimps"
+
+QA_PREBUILT="opt/gimps/mprime"
+
+src_install() {
+       dodir ${I} /var/lib/gimps
+       pax-mark m mprime
+       cp mprime "${D}/${I}"
+       fperms a-w "${I}/mprime"
+       fowners root:0 "${I}"
+       fowners root:0 "${I}/mprime"
+
+       dodoc license.txt readme.txt stress.txt whatsnew.txt undoc.txt
+
+       newinitd "${FILESDIR}/${PN}-26.6-r1-init.d" gimps
+       newconfd "${FILESDIR}/${PN}-25.6-conf.d" gimps
+
+       systemd_dounit "${FILESDIR}/${PN}.service"
+       systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles" "${PN}.conf"
+}
+
+pkg_postinst() {
+       echo
+       einfo "You can use \`/etc/init.d/gimps start\` to start a GIMPS client in the"
+       einfo "background at boot. Have a look at /etc/conf.d/gimps and check some"
+       einfo "configuration options."
+       einfo
+       einfo "If you don't want to use the init script to start gimps, remember to"
+       einfo "pass it an additional command line parameter specifying where the data"
+       einfo "files are to be stored, e.g.:"
+       einfo "   ${I}/mprime -w/var/lib/gimps"
+       echo
+}
+
+pkg_postrm() {
+       echo
+       einfo "GIMPS data files were not removed."
+       einfo "Remove them manually from /var/lib/gimps/"
+       echo
+}