dev-python/pycurl: Version bump to 7.43.0.3
authorPatrick McLean <patrick.mclean@sony.com>
Tue, 22 Oct 2019 00:08:19 +0000 (17:08 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Tue, 22 Oct 2019 00:08:19 +0000 (17:08 -0700)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/pycurl/Manifest
dev-python/pycurl/pycurl-7.43.0.3.ebuild [new file with mode: 0644]

index bbea8f19882f24ea9bf878e79c62ee23067a2024..dc798d3692378fa8bc95030b5146b3ed68865ec3 100644 (file)
@@ -1,2 +1,3 @@
 DIST pycurl-7.43.0.2.tar.gz 214212 BLAKE2B dae74be194334809048782de6a1adef8405e123464ffb0cad02d998d82fb59579d54bb7c5150895224d7622edfe4375f7b2336abd381270b5f64f44b09c8612f SHA512 8635fb33107c9351b7527036b8ab16d76aad72c2170643928034641770d07ab1507a8b2adc8b1a1dcfff29272f55cb00fee65abfcc0c639db14fdc20fc3a0fd0
+DIST pycurl-7.43.0.3.tar.gz 215003 BLAKE2B 2f1e61bd52873906a2d0480ab316c9026f2722cde14c059884ee552a2340fe6b646b4021326f72730aa9eed82f57b5ba923d19c2b8dfadb7a8f8819982116e7a SHA512 eec5c5f10b9a78bcf7e786368cdd5dc165faa4bb646df39ad52c1dfe8110e3e56456f5961f63ab7b460e51e56c41e66a0fc4652c8132411f1dee4074b3cffc00
 DIST pycurl-7.43.0.tar.gz 182522 BLAKE2B af6c85934565d851ea2280253ec6c61ab85f2dea047c83fc5ad65a6f05d3b8bf97932a161ae171c573a7333a99f2a25d4280c70be7ed3aef5eae19b5c392f5c7 SHA512 7442462c74c19964b9d72976e9b92bf68bb37debc1401bc399590bea42704065da13d6de710e795eeae79a4651b9a08841d50454243cb0994c7eb1c1bab233a5
diff --git a/dev-python/pycurl/pycurl-7.43.0.3.ebuild b/dev-python/pycurl/pycurl-7.43.0.3.ebuild
new file mode 100644 (file)
index 0000000..9b0c7f9
--- /dev/null
@@ -0,0 +1,75 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# The selftests fail with pypy, and urlgrabber segfaults for me.
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="python binding for curl/libcurl"
+HOMEPAGE="
+       https://github.com/pycurl/pycurl
+       https://pypi.org/project/pycurl/
+       http://pycurl.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="curl_ssl_gnutls curl_ssl_libressl curl_ssl_nss +curl_ssl_openssl examples ssl test"
+
+# Depend on a curl with curl_ssl_* USE flags.
+# libcurl must not be using an ssl backend we do not support.
+# If the libcurl ssl backend changes pycurl should be recompiled.
+# If curl uses gnutls, depend on at least gnutls 2.11.0 so that pycurl
+# does not need to initialize gcrypt threading and we do not need to
+# explicitly link to libgcrypt.
+RDEPEND="
+       >=net-misc/curl-7.25.0-r1:=[ssl=]
+       ssl? (
+               net-misc/curl[curl_ssl_gnutls(-)=,curl_ssl_libressl(-)=,curl_ssl_nss(-)=,curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-)]
+               curl_ssl_gnutls? ( >=net-libs/gnutls-2.11.0:= )
+               curl_ssl_libressl? ( dev-libs/libressl:= )
+               curl_ssl_openssl? ( dev-libs/openssl:= )
+       )"
+
+# bottle-0.12.7: https://github.com/pycurl/pycurl/issues/180
+# bottle-0.12.7: https://github.com/defnull/bottle/commit/f35197e2a18de1672831a70a163fcfd38327a802
+DEPEND="${RDEPEND}
+       test? (
+               dev-python/bottle[${PYTHON_USEDEP}]
+               dev-python/flaky[${PYTHON_USEDEP}]
+               dev-python/nose[${PYTHON_USEDEP}]
+               net-misc/curl[curl_ssl_gnutls(-)=,curl_ssl_libressl(-)=,curl_ssl_nss(-)=,curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-),http2]
+               >=dev-python/bottle-0.12.7[${PYTHON_USEDEP}]
+       )"
+# Needed for individual runs of testsuite by python impls.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+       sed -e "/setup_args\['data_files'\] = /d" -i setup.py || die
+       distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+       # Override faulty detection in setup.py, bug 510974.
+       export PYCURL_SSL_LIBRARY=${CURL_SSL/libressl/openssl}
+}
+
+python_compile() {
+       python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+       distutils-r1_python_compile
+}
+
+python_test() {
+       nosetests -a '!standalone,!gssapi' -v --with-flaky || die "Tests fail with ${EPYTHON}"
+       nosetests -a 'standalone' -v --with-flaky || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+       local HTML_DOCS=( doc/. )
+       use examples && dodoc -r examples
+       distutils-r1_python_install_all
+}