dev-python/py-cpuinfo: New package, ebuild written by me
authorJustin Lecher <jlec@gentoo.org>
Wed, 17 Feb 2016 07:55:46 +0000 (08:55 +0100)
committerJustin Lecher <jlec@gentoo.org>
Wed, 17 Feb 2016 08:57:11 +0000 (09:57 +0100)
Package-Manager: portage-2.2.27
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/py-cpuinfo/Manifest [new file with mode: 0644]
dev-python/py-cpuinfo/metadata.xml [new file with mode: 0644]
dev-python/py-cpuinfo/py-cpuinfo-0.1.8.ebuild [new file with mode: 0644]

diff --git a/dev-python/py-cpuinfo/Manifest b/dev-python/py-cpuinfo/Manifest
new file mode 100644 (file)
index 0000000..57bc500
--- /dev/null
@@ -0,0 +1 @@
+DIST py-cpuinfo-0.1.8.tar.gz 15321 SHA256 892abe41eba777c2107c54703dde0c769965c3da79d100d94e4cd5e8a9ba3e59 SHA512 62941ff0a6074c6276568994b54e6b4b12403f3524941c958cb64113ee51e47f38d05a93d5434a17e6b9487ea98f56bed137fe5d82099b4180e0032aeea498d5 WHIRLPOOL 32b81ad3fafb149985960b66fbf1d98765723f2c60794cb9151c99b94b0dda8845fbb1d3373e43761ffe7e8d40623e7634bb41693e2a6a41b2658d2ec73d6e93
diff --git a/dev-python/py-cpuinfo/metadata.xml b/dev-python/py-cpuinfo/metadata.xml
new file mode 100644 (file)
index 0000000..85c4530
--- /dev/null
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="project">
+    <email>python@gentoo.org</email>
+    <name>Python</name>
+  </maintainer>
+  <upstream>
+    <remote-id type="pypi">py-cpuinfo</remote-id>
+    <maintainer status="unknown">
+      <email>matthew.brennan.jones@gmail.com</email>
+      <name>Matthew Brennan Jones</name>
+    </maintainer>
+  </upstream>
+</pkgmetadata>
diff --git a/dev-python/py-cpuinfo/py-cpuinfo-0.1.8.ebuild b/dev-python/py-cpuinfo/py-cpuinfo-0.1.8.ebuild
new file mode 100644 (file)
index 0000000..0cc1f2a
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Get CPU info with pure Python 2 & 3"
+HOMEPAGE="https://github.com/workhorsy/py-cpuinfo http://pypi.python.org/pypi/py-cpuinfo"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# https://github.com/workhorsy/py-cpuinfo/issues/32
+RESTRICT="test"
+
+python_test() {
+       "${PYTHON}" test_suite.py || die
+}