app-i18n/imhangul: tidy
authorAkinori Hattori <hattya@gentoo.org>
Tue, 28 Aug 2018 13:40:12 +0000 (22:40 +0900)
committerAkinori Hattori <hattya@gentoo.org>
Tue, 28 Aug 2018 13:40:12 +0000 (22:40 +0900)
Package-Manager: Portage-2.3.40, Repoman-2.3.9

app-i18n/imhangul/imhangul-2.1.0-r1.ebuild [new file with mode: 0644]
app-i18n/imhangul/imhangul-2.1.0.ebuild [deleted file]
app-i18n/imhangul/imhangul-3.1.1.ebuild

diff --git a/app-i18n/imhangul/imhangul-2.1.0-r1.ebuild b/app-i18n/imhangul/imhangul-2.1.0-r1.ebuild
new file mode 100644 (file)
index 0000000..5f32412
--- /dev/null
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit gnome2-utils
+
+DESCRIPTION="GTK+ 2 Hangul Input Modules"
+HOMEPAGE="https://code.google.com/p/imhangul/"
+SRC_URI="https://imhangul.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="app-i18n/libhangul
+       x11-libs/gtk+:2
+       virtual/libintl"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       sys-devel/gettext"
+
+src_prepare() {
+       default
+       gnome2_environment_reset
+       gnome2_disable_deprecation_warning
+}
+
+src_configure() {
+       econf --with-gtk-im-module-dir="${EPREFIX%/}"/usr/$(get_libdir)/gtk-2.0/$(pkg-config gtk+-2.0 --variable=gtk_binary_version)/immodules
+}
+
+src_install() {
+       default
+       find "${ED}" -name '*.la' -delete || die
+       dodoc ${PN}.conf
+
+       local s
+       insinto /etc/X11/xinit/xinput.d
+       for s in 2{,y} 3{2,9,f,s,y} ahn ro; do
+               newins "${FILESDIR}"/xinput-${PN}${s} ${PN}${s}.conf
+       done
+}
+
+pkg_postinst() {
+       gnome2_query_immodules_gtk2
+       elog
+       elog "If you want to use one of the module as a default input method, "
+       elog
+       elog "export GTK_IM_MODULE=hangul2  # 2 input type"
+       elog "export GTK_IM_MODULE=hangul3f # 3 input type"
+       elog
+}
+
+pkg_postrm() {
+       gnome2_query_immodules_gtk2
+}
diff --git a/app-i18n/imhangul/imhangul-2.1.0.ebuild b/app-i18n/imhangul/imhangul-2.1.0.ebuild
deleted file mode 100644 (file)
index 5503848..0000000
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit gnome2-utils multilib readme.gentoo-r1
-
-DESCRIPTION="Gtk+-2.0 Hangul Input Modules"
-HOMEPAGE="https://code.google.com/p/imhangul/"
-SRC_URI="https://imhangul.googlecode.com/files/${P}.tar.bz2"
-
-SLOT="0"
-LICENSE="LGPL-2.1"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
-
-RDEPEND="
-       >=app-i18n/libhangul-0.0.12
-       >=x11-libs/gtk+-2.2:2
-       virtual/libintl
-"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig
-       sys-devel/gettext
-"
-
-DISABLE_AUTOFORMATTING="yes"
-DOC_CONTENTS="
-If you want to use one of the module as a default input method,
-
-export GTK_IM_MODULE=hangul2  # 2 input type
-export GTK_IM_MODULE=hangul3f # 3 input type
-"
-
-get_gtk_confdir() {
-       # bug #366889
-       if has_version '>=x11-libs/gtk+-2.22.1-r1:2' || has_multilib_profile ; then
-               GTK2_CONFDIR="${GTK2_CONFDIR:=${EPREFIX}/etc/gtk-2.0/$(get_abi_CHOST)}"
-       else
-               GTK2_CONFDIR="${GTK2_CONFDIR:=${EPREFIX}/etc/gtk-2.0}"
-       fi
-       echo ${GTK2_CONFDIR}
-}
-
-src_prepare() {
-       default
-       gnome2_environment_reset
-       gnome2_disable_deprecation_warning
-}
-
-src_configure() {
-       econf \
-               --with-gtk-im-module-dir="${EPREFIX}/usr/$(get_libdir)/gtk-2.0/immodules" \
-               --with-gtk-im-module-file="$(get_gtk_confdir)"
-}
-
-src_install() {
-       default
-       prune_libtool_files --modules
-
-       insinto /etc/X11/xinit/xinput.d
-       newins "${FILESDIR}/xinput-imhangul2" imhangul2.conf
-       newins "${FILESDIR}/xinput-imhangul2y" imhangul2y.conf
-       newins "${FILESDIR}/xinput-imhangul32" imhangul32.conf
-       newins "${FILESDIR}/xinput-imhangul39" imhangul39.conf
-       newins "${FILESDIR}/xinput-imhangul3f" imhangul3f.conf
-       newins "${FILESDIR}/xinput-imhangul3s" imhangul3s.conf
-       newins "${FILESDIR}/xinput-imhangul3y" imhangul3y.conf
-       newins "${FILESDIR}/xinput-imhangulahn" imhangulahn.conf
-       newins "${FILESDIR}/xinput-imhangulro" imhangulro.conf
-
-       dodoc imhangul.conf
-       readme.gentoo_create_doc
-}
-
-pkg_postinst() {
-       gnome2_query_immodules_gtk2
-       readme.gentoo_print_elog
-}
-
-pkg_postrm() {
-       gnome2_query_immodules_gtk2
-}
index 1cebdc2d5fc8fa07a6dcaf95440afcaee30f9532..e99ca8ce861d9e80c85c45de1706192840bc2361 100644 (file)
@@ -1,9 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI="6"
 
-DESCRIPTION="Gtk+-3.0 Hangul Input Modules"
+inherit gnome2-utils
+
+DESCRIPTION="GTK+ 3 Hangul Input Modules"
 HOMEPAGE="https://code.google.com/p/imhangul/"
 SRC_URI="https://imhangul.googlecode.com/files/${P}.tar.bz2"
 
@@ -12,7 +14,7 @@ SLOT="3"
 KEYWORDS="~amd64 ~ppc ~x86"
 IUSE=""
 
-RDEPEND=">=app-i18n/libhangul-0.0.12
+RDEPEND="app-i18n/libhangul
        x11-libs/gtk+:3
        virtual/libintl"
 DEPEND="${RDEPEND}
@@ -21,41 +23,34 @@ DEPEND="${RDEPEND}
 
 src_prepare() {
        default
-
-       # Drop DEPRECATED flags, bug #387825
-       sed -i -e 's:-D[A-Z_]*DISABLE_DEPRECATED:$(NULL):g' Makefile.am Makefile.in || die
+       gnome2_environment_reset
+       gnome2_disable_deprecation_warning
 }
 
 src_configure() {
-       econf --with-gtk-im-module-dir="${EPREFIX}/usr/$(get_libdir)/gtk-3.0/$(pkg-config gtk+-3.0 --variable=gtk_binary_version)/immodules"
+       econf --with-gtk-im-module-dir="${EPREFIX%/}"/usr/$(get_libdir)/gtk-3.0/$(pkg-config gtk+-3.0 --variable=gtk_binary_version)/immodules
 }
 
 src_install() {
        default
-       dodoc imhangul.conf
+       find "${ED}" -name '*.la' -delete || die
+       dodoc ${PN}.conf
 
+       local s
        insinto /etc/X11/xinit/xinput.d
-       newins "${FILESDIR}/xinput-imhangul2" imhangul2.conf
-       newins "${FILESDIR}/xinput-imhangul2y" imhangul2y.conf
-       newins "${FILESDIR}/xinput-imhangul32" imhangul32.conf
-       newins "${FILESDIR}/xinput-imhangul39" imhangul39.conf
-       newins "${FILESDIR}/xinput-imhangul3f" imhangul3f.conf
-       newins "${FILESDIR}/xinput-imhangul3s" imhangul3s.conf
-       newins "${FILESDIR}/xinput-imhangul3y" imhangul3y.conf
-       newins "${FILESDIR}/xinput-imhangulahn" imhangulahn.conf
-       newins "${FILESDIR}/xinput-imhangulro" imhangulro.conf
-
-       find "${D}" -name '*.la' -delete || die
+       for s in 2{,y} 3{2,9,f,s,y} ahn ro; do
+               newins "${FILESDIR}"/xinput-${PN}${s} ${PN}${s}.conf
+       done
 }
 
 pkg_postinst() {
        gnome2_query_immodules_gtk3
-       elog ""
+       elog
        elog "If you want to use one of the module as a default input method, "
-       elog ""
+       elog
        elog "export GTK_IM_MODULE=hangul2  # 2 input type"
        elog "export GTK_IM_MODULE=hangul3f # 3 input type"
-       elog ""
+       elog
 }
 
 pkg_postrm() {