dev-ruby/git: add 1.7.0
authorHans de Graaff <graaff@gentoo.org>
Thu, 21 May 2020 05:15:15 +0000 (07:15 +0200)
committerHans de Graaff <graaff@gentoo.org>
Thu, 21 May 2020 05:15:39 +0000 (07:15 +0200)
Drop ~ppc, ~ppc64, ~x86 due to new dependency, bug 724386

Closes: https://bugs.gentoo.org/723806
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
dev-ruby/git/Manifest
dev-ruby/git/git-1.7.0.ebuild [new file with mode: 0644]

index 5c714e4aff2980ebded4501d52acc02d9602ad86..b0e32c79e93676017a5cd6a43b2dadb9f00dbedf 100644 (file)
@@ -1 +1,2 @@
 DIST git-1.5.0.tar.gz 128607 BLAKE2B e2bf19af6c0dd95917b7f599ce2e9b0b4237da78020a86cab5c5985b6944f0921a8f245ef860b9e1faf31761296c4cb6a685ca8d6033e3a8ca7086eef8a9e75b SHA512 001b2e93c1a1f5010026e4b6ea280cc6d7649903cc6faec277b2389bd74fd274c6b2daa465bb66ad7e15f7bdc4b09e20e8c1cc1a55ccfd4ab80ec12bf8562af2
+DIST git-1.7.0.tar.gz 142017 BLAKE2B cb05ef711582b98b420c143dce8fcc3d932c7509ab8c5577a46d70f180ee37d865d7268f56c133d3327ed27058a4c5cd7b03a6c602c665d2f574bdec476c6eec SHA512 c90cd3fe46767a4db5391eb85534e3801f1bd2f345a324ee89d3c04c4348aef09a5424760c59a079d51f3fa003c3b31d30907bfcff4b854adf3b96339d25a8a0
diff --git a/dev-ruby/git/git-1.7.0.ebuild b/dev-ruby/git/git-1.7.0.ebuild
new file mode 100644 (file)
index 0000000..67c3384
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="git.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library for using Git in Ruby"
+HOMEPAGE="https://github.com/schacon/ruby-git"
+SRC_URI="https://github.com/schacon/ruby-git/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="ruby-git-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND+="test? ( >=dev-vcs/git-1.6.0.0 app-arch/tar )"
+RDEPEND+=">=dev-vcs/git-1.6.0.0"
+
+ruby_add_rdepend ">=dev-ruby/rchardet-1.8:1"
+
+ruby_add_bdepend "test? ( dev-ruby/bundler dev-ruby/test-unit:2 )"
+
+all_ruby_prepare() {
+       # Don't use hardcoded /tmp directory.
+       sed -i -e "s:/tmp:${TMPDIR}:" tests/units/test_archive.rb tests/test_helper.rb || die
+}