dev-python/defcon: Bump to 0.6.0
authorPacho Ramos <pacho@gentoo.org>
Sat, 14 Sep 2019 20:37:41 +0000 (22:37 +0200)
committerPacho Ramos <pacho@gentoo.org>
Sat, 14 Sep 2019 20:37:41 +0000 (22:37 +0200)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
dev-python/defcon/Manifest
dev-python/defcon/defcon-0.6.0.ebuild [new file with mode: 0644]

index a7e76ce1d9438525d2eadd42ce08b8bd781ff265..453f27c943ad4aa2f5b6886705ddd7e0c14a948c 100644 (file)
@@ -1 +1,2 @@
 DIST defcon-0.5.3.tar.gz 439149 BLAKE2B 5407eeb8c9bb8e63056d0d42e653eb3bad793b17139fc31f153b12f7ae604aa6615442556f5360f84cc29dfd9674b8117a9022a1e4bdc62324c31378b4c075f1 SHA512 5975c2c0054a1c5d067414b5fe02dc4546fffd12d316c6773ce48425276d7ca7b4e132b772fab2ebc4e683170d02592e1917a67f0dbad64a4c2f2a6a3bfae9ce
+DIST defcon-0.6.0.tar.gz 403682 BLAKE2B c85cf4f846cab3f7543dcec885221e9f828cdf56fb1a373c9d06b27a29c1ab22fc9702d2ce561af97e3d4aa3b03712538ce0b29a0042fa4a0fea6f11eacba69b SHA512 b981c87d2355dc83b5da0ea4879707336ade8ea4d6ca2bc13da064367938579f2a60dfa5b1c0fd3629f4a2de97676e4f02f30f99a6116049cc2a10abd13a3d7b
diff --git a/dev-python/defcon/defcon-0.6.0.ebuild b/dev-python/defcon/defcon-0.6.0.ebuild
new file mode 100644 (file)
index 0000000..f39240f
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="A set of UFO based objects for use in font editing applications"
+HOMEPAGE="https://github.com/typesupply/defcon"
+SRC_URI="https://github.com/typesupply/defcon/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=dev-python/fonttools-3.31.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+python_test() {
+       esetup.py test
+}