dev-python/photutils: version bump
authorSébastien Fabbro <bicatali@gentoo.org>
Fri, 3 Mar 2017 19:36:50 +0000 (19:36 +0000)
committerSébastien Fabbro <bicatali@gentoo.org>
Fri, 3 Mar 2017 19:37:09 +0000 (19:37 +0000)
Package-Manager: Portage-2.3.4, Repoman-2.3.2

dev-python/photutils/Manifest
dev-python/photutils/photutils-0.3.1.ebuild [moved from dev-python/photutils/photutils-0.2.2.ebuild with 78% similarity]

index 1d00d6f00d81c76c4ab23bbbaabbabdd593642c5..dd5bbb1b4430370e992fdac9a79f84d7ec573b39 100644 (file)
@@ -1,2 +1,2 @@
-DIST photutils-0.2.2.tar.gz 558662 SHA256 c64aef453a9be4d1d90bb6a498ca8021a2d7929fca705dbd6636c82ca46eb17f SHA512 b8a071e8d6722b3e174bf89adcc9696aa7556dfb85b21cf8c6acd37bda1f829b79a9a9d93320d70889d6df458a238ed6c4dda7e9b831284f3b52f948ddb268e8 WHIRLPOOL f56ae82c9d54780c319270cec845c953bfa213e7a4d05b5aa5242aaa2e898e9acabe3d27ec76e655a0cba787c991fc91024ee14cc92a1c945af0639436f005e2
+DIST photutils-0.3.1.tar.gz 633814 SHA256 de1d102976f359079b00af62068f103d52a5d5b4931160c969a46a8eb9888209 SHA512 62f7b838e09cb76d0c3b400524340861d882455d305fc31bb062c5853018f0133a4364a5b5e5166101328ad931d474823dd59ab7e58fdcb68bd824dd2ed34959 WHIRLPOOL bcb851eca37d604ab40cbc27e434d2e6d92e6e3ffb8f941d21e270aae54644e6d1fc2d5c639d975df7e443c4a806dd69bc9a3eb5c4eff97acbdad94bf3517f4e
 DIST photutils-0.3.tar.gz 620001 SHA256 7a746229c1d538b671806c48f561fb7d85fabf460b23b828a8af8a66e0097872 SHA512 3b5ddbc424d28d6760751a8e7a447822200d310143d5103cbc39ea1b82f55f78cee3732efdf7a0000bd8835bf6c421072941f22f7daa1e5b6766ff7bf93ae6aa WHIRLPOOL 409ae335793dc14204650cc06ca6e1ba439ebbb84e3f8f41be21168c24928ef732981021c835754f5605521d7fb6f36ce43b5f6687f52e8c42096ef5918b89e4
similarity index 78%
rename from dev-python/photutils/photutils-0.2.2.ebuild
rename to dev-python/photutils/photutils-0.3.1.ebuild
index 08eb4a7b99dcf2787093c788618057bb8345d6e5..f771db8b3779c4ea80cc8dd452cf9fffa7c62d20 100644 (file)
@@ -1,9 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
 
 PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
 inherit distutils-r1 virtualx
 
 DESCRIPTION="Python package for image astronomical photometry"
@@ -21,15 +22,19 @@ RDEPEND="
        dev-python/matplotlib[${PYTHON_USEDEP}]
        dev-python/numpy[${PYTHON_USEDEP}]
        sci-libs/scikits_image[${PYTHON_USEDEP}]
-       sci-libs/scipy[${PYTHON_USEDEP}]"
+       sci-libs/scipy[${PYTHON_USEDEP}]
+"
 DEPEND="${RDEPEND}
        dev-python/astropy-helpers[${PYTHON_USEDEP}]
        dev-python/setuptools[${PYTHON_USEDEP}]
        doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
 
 python_prepare_all() {
        sed -i -e '/auto_use/s/True/False/' setup.cfg || die
+       export MPLCONFIGDIR="${T}"
+       echo "backend: Agg" > "${MPLCONFIGDIR}"/matplotlibrc
        distutils-r1_python_prepare_all
 }
 
@@ -37,9 +42,8 @@ python_compile_all() {
        if use doc; then
                python_setup
                VARTEXFONTS="${T}"/fonts \
-                       MPLCONFIGDIR="${BUILD_DIR}" \
-                       PYTHONPATH="${BUILD_DIR}"/lib \
-                       esetup.py build_sphinx
+                                  PYTHONPATH="${BUILD_DIR}"/lib \
+                                  esetup.py build_sphinx --no-intersphinx
        fi
 }