dev-cpp/aixlog: New package
authorChristian Buchinger <cb-gentoo@guya.de>
Fri, 5 Oct 2018 10:14:39 +0000 (12:14 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Sun, 7 Oct 2018 17:01:47 +0000 (19:01 +0200)
Closes: https://bugs.gentoo.org/667794
Signed-off-by: Christian Buchinger <cb-gentoo@guya.de>
Package-Manager: Portage-2.3.50, Repoman-2.3.11
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-cpp/aixlog/Manifest [new file with mode: 0644]
dev-cpp/aixlog/aixlog-1.2.1.ebuild [new file with mode: 0644]
dev-cpp/aixlog/aixlog-9999.ebuild [new file with mode: 0644]
dev-cpp/aixlog/metadata.xml [new file with mode: 0644]

diff --git a/dev-cpp/aixlog/Manifest b/dev-cpp/aixlog/Manifest
new file mode 100644 (file)
index 0000000..1704731
--- /dev/null
@@ -0,0 +1 @@
+DIST aixlog-1.2.1.tar.gz 11396 BLAKE2B 88cdc775acfd91ee74306fedd6429865f10bcd7cbe9b45f861463489330d74b017611078ca362a00994983dde746ba086a056c3da53b06099f200810d65c0c04 SHA512 776558fdd911f0cc9e8d467bf8e00a1930d2e51bb8ccd5f36f95955fefecab65faf575a80fdaacfe83fd32808f8b9c2e0323b16823e0431300df7bc0c1dfde12
diff --git a/dev-cpp/aixlog/aixlog-1.2.1.ebuild b/dev-cpp/aixlog/aixlog-1.2.1.ebuild
new file mode 100644 (file)
index 0000000..1246304
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Header-only C++ logging library"
+HOMEPAGE="https://github.com/badaix/aixlog"
+
+if [[ ${PV} == *9999 ]] ; then
+       inherit cmake-utils git-r3
+
+       EGIT_REPO_URI="https://github.com/badaix/aixlog.git"
+       EGIT_BRANCH="develop"
+else
+       inherit cmake-utils
+
+       SRC_URI="https://github.com/badaix/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+       KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+src_configure() {
+       local mycmakeargs=( -DBUILD_EXAMPLE=OFF )
+
+       cmake-utils_src_configure
+}
diff --git a/dev-cpp/aixlog/aixlog-9999.ebuild b/dev-cpp/aixlog/aixlog-9999.ebuild
new file mode 100644 (file)
index 0000000..1246304
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Header-only C++ logging library"
+HOMEPAGE="https://github.com/badaix/aixlog"
+
+if [[ ${PV} == *9999 ]] ; then
+       inherit cmake-utils git-r3
+
+       EGIT_REPO_URI="https://github.com/badaix/aixlog.git"
+       EGIT_BRANCH="develop"
+else
+       inherit cmake-utils
+
+       SRC_URI="https://github.com/badaix/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+       KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+src_configure() {
+       local mycmakeargs=( -DBUILD_EXAMPLE=OFF )
+
+       cmake-utils_src_configure
+}
diff --git a/dev-cpp/aixlog/metadata.xml b/dev-cpp/aixlog/metadata.xml
new file mode 100644 (file)
index 0000000..c2a58d8
--- /dev/null
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>cb-gentoo@guya.de</email>
+               <name>Christian Buchinger</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+       <upstream>
+               <maintainer status="active">
+                       <name>Johannes Pohl</name>
+                       <email>github@badaix.de</email>
+               </maintainer>
+               <bugs-to>https://github.com/badaix/aixlog/issues</bugs-to>
+               <remote-id type="github">badaix/aixlog</remote-id>
+       </upstream>
+</pkgmetadata>