dev-perl/Email-LocalDelivery: Fix deps for bug #661462
authorKent Fredric <kentnl@gentoo.org>
Wed, 10 Jul 2019 15:41:46 +0000 (03:41 +1200)
committerKent Fredric <kentnl@gentoo.org>
Wed, 10 Jul 2019 15:42:08 +0000 (03:42 +1200)
- Convert to EAPI6
- Enable parallel tests
- Square up dependencies
- Add missing Capture-Tiny test dependency

Bug: https://bugs.gentoo.org/661462
Package-Manager: Portage-2.3.66, Repoman-2.3.16
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/Email-LocalDelivery/Email-LocalDelivery-1.200.0-r2.ebuild [new file with mode: 0644]

diff --git a/dev-perl/Email-LocalDelivery/Email-LocalDelivery-1.200.0-r2.ebuild b/dev-perl/Email-LocalDelivery/Email-LocalDelivery-1.200.0-r2.ebuild
new file mode 100644 (file)
index 0000000..a012f21
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=RJBS
+DIST_VERSION=1.200
+inherit perl-module
+
+DESCRIPTION="Local delivery of RFC2822 message format and headers"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND="
+       virtual/perl-Carp
+       >=dev-perl/Email-Simple-1.998.0
+       >=dev-perl/Email-FolderType-0.700.0
+       virtual/perl-File-Path
+       >=dev-perl/File-Path-Expand-1.10.0
+"
+DEPEND="${RDEPEND}
+       >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+       test? (
+               dev-perl/Capture-Tiny
+               >=virtual/perl-Test-Simple-0.960.0
+       )
+"