sys-libs/musl: remove older versions
authorAnthony G. Basile <blueness@gentoo.org>
Sun, 27 Jan 2019 12:44:17 +0000 (07:44 -0500)
committerAnthony G. Basile <blueness@gentoo.org>
Sun, 27 Jan 2019 12:44:17 +0000 (07:44 -0500)
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

sys-libs/musl/Manifest
sys-libs/musl/musl-1.1.19.ebuild [deleted file]
sys-libs/musl/musl-1.1.20.ebuild [deleted file]

index e69465222333b238fab514cb25ba3c2276969493..cdbdd35d7e731ae24c2fc40415bd467b8de039ee 100644 (file)
@@ -1,6 +1,5 @@
 DIST getconf.c 11614 BLAKE2B ba49a573fc16d51780a0b0b81fbf7b64a1142f1dbad203c9609a59b6b07e7404f676c415383ae88c0aede95694821f6ee381bffd93cc3330501e17dc07d122bd SHA512 0d80f37b34a35e3d14b012257c50862dfeb9d2c81139ea2dfa101d981d093b009b9fa450ba27a708ac59377a48626971dfc58e20a3799084a65777a0c32cbc7d
 DIST getent.c 9438 BLAKE2B dc20353583c10a001bd8fe8474f32b70254dc56da186d1cdbaf4081570c3d7a10497024da5815a485fc4728adc9eebd270aec99ba93b7546b38c728978e3e00b SHA512 b35de9847353b273516162ed4828a810c6130fc5b7de44ee4433003b3f99647b25792d9b1c40dfc67069add11f3fb850e5c35d4f1912dccac108059bbbdfd5a2
 DIST iconv.c 2577 BLAKE2B 070ca87b30c90ab98c27d5faf7a2fcb64ff7c67ca212ee6072165b2146979c551f714954dbd465462a171837c59b6ea027e0206458a2df0f977e45f01be3ce48 SHA512 9d42d66fb1facce2b85dad919be5be819ee290bd26ca2db00982b2f8e055a0196290a008711cbe2b18ec9eee8d2270e3b3a4692c5a1b807013baa5c2b70a2bbf
-DIST musl-1.1.19.tar.gz 960319 BLAKE2B 3e69de2ed9384fe200bb64e603f342a930acf035cf7bac8fe3cd4225800424207df2b73fe6fabf3147fc8023a655839c33f50c0be8e30f51f76b84aba4de30b5 SHA512 abee52d53af4b3c14c9088866c911a24d2b6ef67dc494f38a7a09dfe77250026f77528c24c52469c89cffa8ced2f0fa95badbdcf8d4460c90faba47e3927bcc5
 DIST musl-1.1.20.tar.gz 977827 BLAKE2B c8ce3cc1885e8103e1cf9d67183d89e5e222fd317158b20f25a8e1855a3cd5d16c79b4d95ff896fe7262f233141c3f3ca4dfc6a26a2373ab1d29a3c66b904e61 SHA512 d3a7a30aa375ca50d7dcfbd618581d59e1aa5378417f50a0ca5510099336fd74cc9db468e05c93dda3067abd890f6bd47af226c3446bb833adf0a5054bff2e5d
 DIST musl-1.1.21.tar.gz 987341 BLAKE2B e080ee040ad5b7901f72d27a7e269ae4173eed8774510546abc8e53727a7443ed3590a802e6d750e2841313efb23e0c4097e3bf6232f4b84a777317e9b8260e7 SHA512 fa6c4cc012626c5e517e0e10926fc845e3aa5f863ffaceeb38ac5b9ce0af631a37f6b94f470997db09aa0d5e03f4f28a2db83484b0f98481bea2239c1989d363
diff --git a/sys-libs/musl/musl-1.1.19.ebuild b/sys-libs/musl/musl-1.1.19.ebuild
deleted file mode 100644 (file)
index 9c2f1c1..0000000
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils flag-o-matic multilib toolchain-funcs
-if [[ ${PV} == "9999" ]] ; then
-       EGIT_REPO_URI="git://git.musl-libc.org/musl"
-       inherit git-r3
-       SRC_URI="
-       https://dev.gentoo.org/~blueness/musl-misc/getconf.c
-       https://dev.gentoo.org/~blueness/musl-misc/getent.c
-       https://dev.gentoo.org/~blueness/musl-misc/iconv.c"
-       KEYWORDS=""
-else
-       SRC_URI="http://www.musl-libc.org/releases/${P}.tar.gz
-       https://dev.gentoo.org/~blueness/musl-misc/getconf.c
-       https://dev.gentoo.org/~blueness/musl-misc/getent.c
-       https://dev.gentoo.org/~blueness/musl-misc/iconv.c"
-       KEYWORDS="-* amd64 arm arm64 ~mips ppc x86"
-fi
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
-       if [[ ${CATEGORY} == cross-* ]] ; then
-               export CTARGET=${CATEGORY#cross-}
-       fi
-fi
-
-DESCRIPTION="Light, fast and simple C library focused on standards-conformance and safety"
-HOMEPAGE="http://www.musl-libc.org/"
-LICENSE="MIT LGPL-2 GPL-2"
-SLOT="0"
-IUSE="headers-only"
-
-QA_SONAME="/usr/lib/libc.so"
-QA_DT_NEEDED="/usr/lib/libc.so"
-
-is_crosscompile() {
-       [[ ${CHOST} != ${CTARGET} ]]
-}
-
-just_headers() {
-       use headers-only && is_crosscompile
-}
-
-pkg_setup() {
-       if [ ${CTARGET} == ${CHOST} ] ; then
-               case ${CHOST} in
-               *-musl*) ;;
-               *) die "Use sys-devel/crossdev to build a musl toolchain" ;;
-               esac
-       fi
-}
-
-src_configure() {
-       tc-getCC ${CTARGET}
-       just_headers && export CC=true
-
-       local sysroot
-       is_crosscompile && sysroot=/usr/${CTARGET}
-       ./configure \
-               --target=${CTARGET} \
-               --prefix=${sysroot}/usr \
-               --syslibdir=${sysroot}/lib \
-               --disable-gcc-wrapper || die
-}
-
-src_compile() {
-       emake obj/include/bits/alltypes.h
-       just_headers && return 0
-
-       emake
-       if [[ ${CATEGORY} != cross-* ]] ; then
-               $(tc-getCC) ${CFLAGS} "${DISTDIR}"/getconf.c -o "${T}"/getconf || die
-               $(tc-getCC) ${CFLAGS} "${DISTDIR}"/getent.c -o "${T}"/getent || die
-               $(tc-getCC) ${CFLAGS} "${DISTDIR}"/iconv.c -o "${T}"/iconv || die
-       fi
-}
-
-src_install() {
-       local target="install"
-       just_headers && target="install-headers"
-       emake DESTDIR="${D}" ${target}
-       just_headers && return 0
-
-       # musl provides ldd via a sym link to its ld.so
-       local sysroot
-       is_crosscompile && sysroot=/usr/${CTARGET}
-       local ldso=$(basename "${D}"${sysroot}/lib/ld-musl-*)
-       dosym ${sysroot}/lib/${ldso} ${sysroot}/usr/bin/ldd
-
-       if [[ ${CATEGORY} != cross-* ]] ; then
-               local arch=$("${D}"usr/lib/libc.so 2>&1 | sed -n '1s/^musl libc (\(.*\))$/\1/p')
-               [[ -e "${D}"/lib/ld-musl-${arch}.so.1 ]] || die
-               cp "${FILESDIR}"/ldconfig.in "${T}" || die
-               sed -e "s|@@ARCH@@|${arch}|" "${T}"/ldconfig.in > "${T}"/ldconfig || die
-               into /
-               dosbin "${T}"/ldconfig
-               into /usr
-               dobin "${T}"/getconf
-               dobin "${T}"/getent
-               dobin "${T}"/iconv
-               echo 'LDPATH="include ld.so.conf.d/*.conf"' > "${T}"/00musl || die
-               doenvd "${T}"/00musl || die
-       fi
-}
-
-pkg_postinst() {
-       is_crosscompile && return 0
-
-       [ "${ROOT}" != "/" ] && return 0
-
-       ldconfig || die
-       # reload init ...
-       /sbin/telinit U 2>/dev/null
-}
diff --git a/sys-libs/musl/musl-1.1.20.ebuild b/sys-libs/musl/musl-1.1.20.ebuild
deleted file mode 100644 (file)
index 768c9e7..0000000
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils flag-o-matic multilib toolchain-funcs
-if [[ ${PV} == "9999" ]] ; then
-       EGIT_REPO_URI="git://git.musl-libc.org/musl"
-       inherit git-r3
-       SRC_URI="
-       https://dev.gentoo.org/~blueness/musl-misc/getconf.c
-       https://dev.gentoo.org/~blueness/musl-misc/getent.c
-       https://dev.gentoo.org/~blueness/musl-misc/iconv.c"
-       KEYWORDS=""
-else
-       SRC_URI="http://www.musl-libc.org/releases/${P}.tar.gz
-       https://dev.gentoo.org/~blueness/musl-misc/getconf.c
-       https://dev.gentoo.org/~blueness/musl-misc/getent.c
-       https://dev.gentoo.org/~blueness/musl-misc/iconv.c"
-       KEYWORDS="-* amd64 ~arm ~arm64 ~mips ~ppc x86"
-fi
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
-       if [[ ${CATEGORY} == cross-* ]] ; then
-               export CTARGET=${CATEGORY#cross-}
-       fi
-fi
-
-DESCRIPTION="Light, fast and simple C library focused on standards-conformance and safety"
-HOMEPAGE="http://www.musl-libc.org/"
-LICENSE="MIT LGPL-2 GPL-2"
-SLOT="0"
-IUSE="headers-only"
-
-QA_SONAME="/usr/lib/libc.so"
-QA_DT_NEEDED="/usr/lib/libc.so"
-
-is_crosscompile() {
-       [[ ${CHOST} != ${CTARGET} ]]
-}
-
-just_headers() {
-       use headers-only && is_crosscompile
-}
-
-pkg_setup() {
-       if [ ${CTARGET} == ${CHOST} ] ; then
-               case ${CHOST} in
-               *-musl*) ;;
-               *) die "Use sys-devel/crossdev to build a musl toolchain" ;;
-               esac
-       fi
-}
-
-src_configure() {
-       tc-getCC ${CTARGET}
-       just_headers && export CC=true
-
-       local sysroot
-       is_crosscompile && sysroot=/usr/${CTARGET}
-       ./configure \
-               --target=${CTARGET} \
-               --prefix=${sysroot}/usr \
-               --syslibdir=${sysroot}/lib \
-               --disable-gcc-wrapper || die
-}
-
-src_compile() {
-       emake obj/include/bits/alltypes.h
-       just_headers && return 0
-
-       emake
-       if [[ ${CATEGORY} != cross-* ]] ; then
-               $(tc-getCC) ${CFLAGS} "${DISTDIR}"/getconf.c -o "${T}"/getconf || die
-               $(tc-getCC) ${CFLAGS} "${DISTDIR}"/getent.c -o "${T}"/getent || die
-               $(tc-getCC) ${CFLAGS} "${DISTDIR}"/iconv.c -o "${T}"/iconv || die
-       fi
-}
-
-src_install() {
-       local target="install"
-       just_headers && target="install-headers"
-       emake DESTDIR="${D}" ${target}
-       just_headers && return 0
-
-       # musl provides ldd via a sym link to its ld.so
-       local sysroot
-       is_crosscompile && sysroot=/usr/${CTARGET}
-       local ldso=$(basename "${D}"${sysroot}/lib/ld-musl-*)
-       dosym ${sysroot}/lib/${ldso} ${sysroot}/usr/bin/ldd
-
-       if [[ ${CATEGORY} != cross-* ]] ; then
-               local arch=$("${D}"usr/lib/libc.so 2>&1 | sed -n '1s/^musl libc (\(.*\))$/\1/p')
-               [[ -e "${D}"/lib/ld-musl-${arch}.so.1 ]] || die
-               cp "${FILESDIR}"/ldconfig.in "${T}" || die
-               sed -e "s|@@ARCH@@|${arch}|" "${T}"/ldconfig.in > "${T}"/ldconfig || die
-               into /
-               dosbin "${T}"/ldconfig
-               into /usr
-               dobin "${T}"/getconf
-               dobin "${T}"/getent
-               dobin "${T}"/iconv
-               echo 'LDPATH="include ld.so.conf.d/*.conf"' > "${T}"/00musl || die
-               doenvd "${T}"/00musl || die
-       fi
-}
-
-pkg_postinst() {
-       is_crosscompile && return 0
-
-       [ "${ROOT}" != "/" ] && return 0
-
-       ldconfig || die
-       # reload init ...
-       /sbin/telinit U 2>/dev/null
-}