dev-python/vcrpy: Remove old
authorMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 12:32:37 +0000 (14:32 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 12:32:37 +0000 (14:32 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/vcrpy/Manifest
dev-python/vcrpy/vcrpy-1.12.0.ebuild [deleted file]

index 2f7f74270b2a3a9d9137487191bd9f774ad5fecc..e1366f948961c679598fd9aacbbf60c0c7b35da1 100644 (file)
@@ -1,3 +1,2 @@
 DIST vcrpy-1.11.1.tar.gz 63122 BLAKE2B da0fabb1eb342eb268923bcf433ac108d06fc111714834e99d9364358064ad0814bff1463f49bea60c59fe901c46fc8b78c4129e9bb4ab6736266f18b3bdf272 SHA512 d883b87d5b3017843dfc2e33241953ada27d50ffda4936ba4326a392acb9c7667474abd054d6e44b0208096cd96b68e87ec9780c0d6fab77369cc4e517617395
-DIST vcrpy-1.12.0.tar.gz 326731 BLAKE2B a0fd5aa3fea1bef336f0864a6d89e7025d2394f89af23ac9a3ed61430c85b9a46584c528398a03debcce646767bd85328360513476bc89ca067e705767fe85fd SHA512 c47d50cd399fa11eb6fd1d210b056ef9768e501799a9774f7338370177754e35b9a9ee43ff5cb7f1f43073624f9011cc1ca230dbdf317c1bccd0ec6b506c61e0
 DIST vcrpy-4.0.2.tar.gz 324196 BLAKE2B 8910ba40bd56c7836a92c120c480e633063c78beb1d7c4dcfffb6180135cf0e28586410307ba3e19b3fa484a72a176dbf877f781ade7bae7c81110fde2eedd32 SHA512 17eebc9574ff14f97ad200b99c50b0440a93fbf38afe8ad95f443370d84c43177ac55ab655ffea7e7985b0cd76124eff3c394898e71a0ba0c434014f07e526f9
diff --git a/dev-python/vcrpy/vcrpy-1.12.0.ebuild b/dev-python/vcrpy/vcrpy-1.12.0.ebuild
deleted file mode 100644 (file)
index 3c66980..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Automatically mock your HTTP interactions to simplify and speed up testing"
-HOMEPAGE="https://github.com/kevin1024/vcrpy"
-#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-SRC_URI="https://github.com/kevin1024/vcrpy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
-       dev-python/pyyaml[${PYTHON_USEDEP}]
-       dev-python/requests[${PYTHON_USEDEP}]
-       >=dev-python/six-1.5[${PYTHON_USEDEP}]
-       dev-python/urllib3[${PYTHON_USEDEP}]
-       dev-python/wrapt[${PYTHON_USEDEP}]
-       dev-python/yarl[${PYTHON_USEDEP}]
-       "
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               ${RDEPEND}
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/pytest-httpbin[${PYTHON_USEDEP}]
-       )"
-
-PATCHES=(
-       "${FILESDIR}"/vcrpy-skip-network-tests.patch
-)
-
-python_test() {
-       py.test -vv -x tests/unit || die
-}