dev-ml/ppx_deriving: Apply conditional patch, backported from upstream, to build...
authorAlexis Ballier <aballier@gentoo.org>
Thu, 13 Jul 2017 22:07:49 +0000 (00:07 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Thu, 13 Jul 2017 22:09:34 +0000 (00:09 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.2

dev-ml/ppx_deriving/files/ocaml405.patch [new file with mode: 0644]
dev-ml/ppx_deriving/ppx_deriving-4.1-r1.ebuild

diff --git a/dev-ml/ppx_deriving/files/ocaml405.patch b/dev-ml/ppx_deriving/files/ocaml405.patch
new file mode 100644 (file)
index 0000000..6f0a5c5
--- /dev/null
@@ -0,0 +1,21 @@
+Index: ppx_deriving-4.1/src/ppx_deriving.cppo.ml
+===================================================================
+--- ppx_deriving-4.1.orig/src/ppx_deriving.cppo.ml
++++ ppx_deriving-4.1/src/ppx_deriving.cppo.ml
+@@ -310,6 +310,7 @@ let free_vars_in_core_type typ =
+       List.map free_in xs |> List.concat
+     | { ptyp_desc = Ptyp_alias (x, name) } -> [name] @ free_in x
+     | { ptyp_desc = Ptyp_poly (bound, x) } ->
++      let bound = List.map (fun x -> x.Location.txt) bound in
+       List.filter (fun y -> not (List.mem y bound)) (free_in x)
+     | { ptyp_desc = Ptyp_variant (rows, _, _) } ->
+       List.map (
+@@ -401,7 +402,7 @@ let binop_reduce x a b =
+   [%expr [%e x] [%e a] [%e b]]
+ let strong_type_of_type ty =
+-  let free_vars = free_vars_in_core_type ty in
++  let free_vars = List.map Location.mknoloc (free_vars_in_core_type ty) in
+   Typ.force_poly @@ Typ.poly free_vars ty
+ let derive path pstr_loc item attributes fn arg =
index c0d348838f6c9c539ce3b36ee189138b03781e33..5adaa541c9c45fd41c6f12b02e510fd76b35f79b 100644 (file)
@@ -24,6 +24,7 @@ DEPEND="${RDEPEND}
 
 src_prepare() {
        epatch "${FILESDIR}/ocb011.patch"
+       has_version '>=dev-lang/ocaml-4.05_rc' && epatch "${FILESDIR}/ocaml405.patch"
 }
 
 src_compile() {