sys-devel/clang-runtime: Bump to 7.0.0rc2
authorMichał Górny <mgorny@gentoo.org>
Tue, 28 Aug 2018 15:41:04 +0000 (17:41 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 28 Aug 2018 16:00:38 +0000 (18:00 +0200)
sys-devel/clang-runtime/clang-runtime-7.0.0_rc2.ebuild [new file with mode: 0644]

diff --git a/sys-devel/clang-runtime/clang-runtime-7.0.0_rc2.ebuild b/sys-devel/clang-runtime/clang-runtime-7.0.0_rc2.ebuild
new file mode 100644 (file)
index 0000000..0a2d248
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="${PV%_*}"
+KEYWORDS=""
+IUSE="+compiler-rt crt libcxx openmp +sanitize"
+
+RDEPEND="
+       compiler-rt? (
+               ~sys-libs/compiler-rt-${PV}:${SLOT}
+               sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+       )
+       crt? (
+               || (
+                       sys-libs/netbsd-csu[${MULTILIB_USEDEP}]
+                       sys-freebsd/freebsd-lib[${MULTILIB_USEDEP}]
+               )
+       )
+       libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+       openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"
+
+REQUIRED_USE="sanitize? ( compiler-rt )"