app-text/csvfix: inherit missing eutils eclass and fix tests
authorTim Harder <radhermit@gentoo.org>
Thu, 25 Jul 2019 08:47:43 +0000 (02:47 -0600)
committerTim Harder <radhermit@gentoo.org>
Thu, 25 Jul 2019 08:50:21 +0000 (02:50 -0600)
Closes: https://bugs.gentoo.org/630640
Closes: https://bugs.gentoo.org/647986

Signed-off-by: Tim Harder <radhermit@gentoo.org>
app-text/csvfix/csvfix-1.6.ebuild
app-text/csvfix/files/csvfix-1.6-shuffle-test.patch [new file with mode: 0644]

index e79e239ef7de04a35039828ed49fef38c4575d4b..8f35d4536767b87cf404d652a1008ad633aaed43 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
 
-inherit toolchain-funcs versionator vcs-snapshot
+inherit toolchain-funcs versionator vcs-snapshot eutils
 
 MY_PV="$(delete_all_version_separators)"
 DESCRIPTION="A stream editor for manipulating CSV files"
@@ -23,6 +23,7 @@ DEPEND="${RDEPEND}
 PATCHES=(
        "${FILESDIR}"/${P}-makefile.patch
        "${FILESDIR}"/${PN}-1.10a-tests.patch
+       "${FILESDIR}"/${P}-shuffle-test.patch
 )
 
 src_prepare() {
diff --git a/app-text/csvfix/files/csvfix-1.6-shuffle-test.patch b/app-text/csvfix/files/csvfix-1.6-shuffle-test.patch
new file mode 100644 (file)
index 0000000..3916e92
--- /dev/null
@@ -0,0 +1,20 @@
+Fix the expected data output for the shuffle test.
+
+--- a/csvfix/tests/correct/shuffle.test
++++ b/csvfix/tests/correct/shuffle.test
+@@ -5,10 +5,10 @@
+ "Oscar","Wilde","M"\r
+ "Charles","Dickens","M"\r
+ "George","Elliot","F"\r
+-"Charles","Dickens","M"\r
+-"Austen","F","Jane"\r
++"Charles","M","Dickens"\r
++"Jane","F","Austen"\r
+ "Herman","M","Melville"\r
+ "M","Flann","O'Brien"\r
+-"Elliot","George","F"\r
+-"Virginia","Woolf","F"\r
+-"M","Wilde","Oscar"\r
++"George","F","Elliot"\r
++"Woolf","F","Virginia"\r
++"Wilde","M","Oscar"\r