dev-python/wsproto: Bump to 0.15.0
authorMichał Górny <mgorny@gentoo.org>
Mon, 27 Apr 2020 08:27:05 +0000 (10:27 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 27 Apr 2020 08:33:00 +0000 (10:33 +0200)
Closes: https://bugs.gentoo.org/696670
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/wsproto/Manifest
dev-python/wsproto/wsproto-0.15.0.ebuild [new file with mode: 0644]

index 47b64470b1559e89967e08c6117c445118bb1ed2..1173087a7dc9bdf2fe554a88a00d05f723ba9992 100644 (file)
@@ -1 +1,2 @@
 DIST wsproto-0.12.0.tar.gz 45252 BLAKE2B 1be690faba6665b11e2e1c1725935addb132d7008f0ae81e7d5c383a152a5d79389287b3c152cb380e0bdfc97a3438e2a48b62f3c8acf6b501427bc617225ec0 SHA512 159b7f67eff60c2514cfca17036d95017109fe251def6cec132998ac82a037484e3e248d4335539fd03491f56c491a7cf51582aa3f74a44d7d150220a875b18d
+DIST wsproto-0.15.0.tar.gz 51765 BLAKE2B 6eae2d2ceeb2d1e870c1ca70db22708fc2e5d10aac6b1d1a44ab00f4b31e18f21fd324c7e8c95e28769f4642601b775dc687eb28b419c5698ed68e617d054599 SHA512 c9666ec65374181da762f460f0c394a5bb599f8a0666989fb2d53e5e8822f5ebdd28eae3098e115d5bbacf6d6e1dd33a9cfeb808d569e1a01025eefaff18c531
diff --git a/dev-python/wsproto/wsproto-0.15.0.ebuild b/dev-python/wsproto/wsproto-0.15.0.ebuild
new file mode 100644 (file)
index 0000000..b4e0f09
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="WebSockets state-machine based protocol implementation"
+HOMEPAGE="https://github.com/python-hyper/wsproto https://pypi.python.org/pypi/wsproto"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       >=dev-python/h11-0.8[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               dev-python/dataclasses[${PYTHON_USEDEP}]
+       ' python3_6)
+"
+
+distutils_enable_tests pytest