app-vim/vim-go: new package.
authorPatrice Clement <monsieurp@gentoo.org>
Sat, 28 Oct 2017 22:48:14 +0000 (00:48 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Sun, 29 Oct 2017 06:57:29 +0000 (07:57 +0100)
vim-go is a Go development plugin for Vim.

Package-Manager: Portage-2.3.8, Repoman-2.3.3
Bug: https://bugs.gentoo.org/635420

app-vim/vim-go/Manifest [new file with mode: 0644]
app-vim/vim-go/metadata.xml [new file with mode: 0644]
app-vim/vim-go/vim-go-1.13.ebuild [new file with mode: 0644]

diff --git a/app-vim/vim-go/Manifest b/app-vim/vim-go/Manifest
new file mode 100644 (file)
index 0000000..5620733
--- /dev/null
@@ -0,0 +1 @@
+DIST vim-go-1.13.zip 900566 SHA256 b4a6212becad775f90dedcb8045b04bf691f32c258c1fead68d5fbb7b775b463 SHA512 3a1818c126c6ab01cd6993336c9e87f88357375b5252e0aeed434dccd0514cbcb1b7c96dce2aaf8f8c2e21909a17bf4bbb39a386ee1f7049b50a85ed9c635817 WHIRLPOOL 0c92fe8f0f685401a9014124a0fb7341b7891dc5346b5af50124a5d2435614d11ed9d24922e0d5fe4cbfe0045ee0539769b3592ff5a0fdecf0f260a090e7b28d
diff --git a/app-vim/vim-go/metadata.xml b/app-vim/vim-go/metadata.xml
new file mode 100644 (file)
index 0000000..a34620b
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>vim@gentoo.org</email>
+               <name>Gentoo Vim Project</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="github">fatih/vim-go</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/app-vim/vim-go/vim-go-1.13.ebuild b/app-vim/vim-go/vim-go-1.13.ebuild
new file mode 100644 (file)
index 0000000..2cffe30
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Go development plugin for Vim"
+HOMEPAGE="https://github.com/fatih/vim-go"
+SRC_URI="https://github.com/fatih/${PN}/archive/v${PV}.zip -> ${P}.zip"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="$PN"
+
+RESTRICT="test"
+
+src_compile() {
+       # safely skip `make test` triggered by `make` as it runs `go get` commands
+       # TODO: see :GoInstallBinaries (https://github.com/fatih/vim-go/blob/master/doc/vim-go.txt)
+       :;
+}