dev-util/argouml: Port to EAPI 6
authorDavid Seifert <soap@gentoo.org>
Wed, 18 Apr 2018 12:16:17 +0000 (14:16 +0200)
committerDavid Seifert <soap@gentoo.org>
Wed, 18 Apr 2018 16:44:05 +0000 (18:44 +0200)
Closes: https://bugs.gentoo.org/652796
Package-Manager: Portage-2.3.29, Repoman-2.3.9

dev-util/argouml/argouml-0.34.ebuild

index 96dd77d1ac14859f769d4cce312d0fa7e24a2f38..fd031b69ec0febd4e3e0bf9ee40b11f652258fb0 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="3"
+EAPI=6
 
-inherit eutils fdo-mime java-pkg-2
+inherit desktop xdg-utils java-pkg-2
 
 DESCRIPTION="Modelling tool that helps you do your design using UML"
 HOMEPAGE="http://argouml.tigris.org"
@@ -36,13 +36,17 @@ src_install() {
 
        java-pkg_dolauncher ${PN} --main org.argouml.application.Main
 
-       dodoc ${P}/README.txt || die
-
-       if use doc ; then
-               dohtml -r release/{Readme.htm,www}
-               insinto /usr/share/doc/${P}
-               doins "${DISTDIR}/manual-${PV}.pdf"
-               doins "${DISTDIR}/quickguide-${PV}.pdf"
+       dodoc ${P}/README.txt
+
+       if use doc; then
+               find release/ \( -name Thumbs.db -o -name filelist.xml \) \
+                       -delete || die
+               HTML_DOCS=( release/{Readme.htm,www} )
+               DOCS=(
+                       "${DISTDIR}"/manual-${PV}.pdf
+                       "${DISTDIR}"/quickguide-${PV}.pdf
+               )
+               einstalldocs
        fi
 
        newicon ${P}/icon/ArgoIcon128x128.png ${PN}.png || die
@@ -50,9 +54,9 @@ src_install() {
 }
 
 pkg_postinst() {
-       fdo-mime_desktop_database_update
+       xdg_desktop_database_update
 }
 
 pkg_postrm() {
-       fdo-mime_desktop_database_update
+       xdg_desktop_database_update
 }