dev-go/go-spew: converted to use the go eclasses
authorWilliam Hubbs <williamh@gentoo.org>
Mon, 10 Aug 2015 19:47:49 +0000 (14:47 -0500)
committerWilliam Hubbs <williamh@gentoo.org>
Mon, 10 Aug 2015 19:47:49 +0000 (14:47 -0500)
dev-go/go-spew/go-spew-0_pre20150619.ebuild

index 9b9367f2b3da545de3061db4d4ffaf6e5e0e6747..26f65ba85137f3cafdef0745bbe65d05d517cc71 100644 (file)
@@ -13,6 +13,7 @@ else
        KEYWORDS="~amd64"
        EGIT_COMMIT="2df174808ee097f90d259e432cc04442cf60be21"
        SRC_URI="https://${EGO_SRC}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+       inherit golang-vcs-snapshot
 fi
 inherit golang-build
 
@@ -23,37 +24,3 @@ SLOT="0/${PV}"
 IUSE=""
 DEPEND=""
 RDEPEND=""
-
-if [[ ${PV} != *9999* ]]; then
-src_unpack() {
-       local f
-
-       for f in ${A}
-       do
-               case "${f}" in
-                       *.tar|*.tar.gz|*.tar.bz2|*.tar.xz)
-                               local destdir=${WORKDIR}/${P}/src/${EGO_SRC}
-
-                               debug-print "${FUNCNAME}: unpacking ${f} to ${destdir}"
-
-                               # XXX: check whether the directory structure inside is
-                               # fine? i.e. if the tarball has actually a parent dir.
-                               mkdir -p "${destdir}" || die
-                               tar -C "${destdir}" -x --strip-components 1 \
-                                       -f "${DISTDIR}/${f}" || die
-                               ;;
-                       *)
-                               debug-print "${FUNCNAME}: falling back to unpack for ${f}"
-
-                               # fall back to the default method
-                               unpack "${f}"
-                               ;;
-               esac
-       done
-}
-fi
-
-src_install() {
-       rm -rf src/${EGO_SRC}/.git* || die
-       golang-build_src_install
-}