Eliminate redundant "notadded" error filtering. (trunk r9023)
authorZac Medico <zmedico@gentoo.org>
Fri, 21 Dec 2007 03:29:58 +0000 (03:29 -0000)
committerZac Medico <zmedico@gentoo.org>
Fri, 21 Dec 2007 03:29:58 +0000 (03:29 -0000)
svn path=/main/branches/2.1.2/; revision=9024

bin/repoman

index 2596b4b45016acf4ea5e43c9124e6b283e9e5c27..25d6a54beb0156c9512b8dad88a3a05a396f45de 100755 (executable)
@@ -485,9 +485,6 @@ def last():
        for x in qacats:
                if not stats[x]:
                        continue
-               if "notadded" in x and not isCvs:
-                       stats[x] = 0
-                       continue
                dowarn = 1
                if x not in qawarnings:
                        dofail = 1
@@ -1375,7 +1372,7 @@ for x in scanlist:
                if os.stat(checkdir+"/"+y+".ebuild")[0] & 0x0248:
                        stats["file.executable"] += 1
                        fails["file.executable"].append(x+"/"+y+".ebuild")
-               if y not in eadded:
+               if isCvs and y not in eadded:
                        #ebuild not added to cvs
                        stats["ebuild.notadded"]=stats["ebuild.notadded"]+1
                        fails["ebuild.notadded"].append(x+"/"+y+".ebuild")
@@ -1870,9 +1867,6 @@ dofull = mymode not in ("full", "lfull")
 for x in qacats:
        if not stats[x]:
                continue
-       if "notadded" in x and not isCvs:
-               stats[x] = 0
-               continue
        dowarn = 1
        if x not in qawarnings:
                dofail = 1