fix up use invocation
authorMichael Sterrett <mr_bones_@gentoo.org>
Thu, 3 Jun 2004 06:17:35 +0000 (06:17 +0000)
committerMichael Sterrett <mr_bones_@gentoo.org>
Thu, 3 Jun 2004 06:17:35 +0000 (06:17 +0000)
games-action/heroes/ChangeLog
games-action/heroes/Manifest
games-action/heroes/heroes-0.21.ebuild

index 46f84e52e9b45cd86a6dfddef1a3ca5529808271..77dd029eaab807edd64d285ea5a18e300c4aa8b3 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for games-action/heroes
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/heroes/ChangeLog,v 1.4 2003/11/04 22:27:00 weeve Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/heroes/ChangeLog,v 1.5 2004/06/03 06:17:35 mr_bones_ Exp $
+
+  02 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org> heroes-0.21.ebuild:
+  fix up use invocation
 
   04 Nov 2003; Jason Wever <weeve@gentoo.org> heroes-0.21.ebuild:
   Added ggi to IUSE, thanks to ciaranm from #gentoo-sparc for pointing it out.
index 218d9293bcd603f9b1b9d1989a0aa5dc7e871383..3aa3a0a2dbd58b442739be5499e714a5ca700a82 100644 (file)
@@ -1,4 +1,4 @@
-MD5 629b186fe097d16cc43e4748d648acf0 files/digest-heroes-0.21 286
-MD5 668f037dabf211c579350cfb1fa627c3 ChangeLog 1951
-MD5 66153816c6a5da17723e2e8535248b63 heroes-0.21.ebuild 1592
+MD5 c11bcd36d2a507447bea4e41888d65f8 ChangeLog 2054
+MD5 ba080882455ae67f2072eb915bb3825a heroes-0.21.ebuild 1587
 MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 629b186fe097d16cc43e4748d648acf0 files/digest-heroes-0.21 286
index 5532a1ad4bf311a3df75de0217395458ca243f61..d225d1664869c85fd4897b3d515435ce7faf4ab2 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2004 Gentoo Technologies, Inc.
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/heroes/heroes-0.21.ebuild,v 1.5 2004/03/14 18:26:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/heroes/heroes-0.21.ebuild,v 1.6 2004/06/03 06:17:35 mr_bones_ Exp $
 
 inherit games
 
@@ -29,18 +29,19 @@ DEPEND="virtual/x11
        sdl? ( media-libs/libsdl media-libs/sdl-mixer )
        ggi? ( media-libs/libggi media-libs/libgii media-libs/libmikmod )"
 
-S=${WORKDIR}
+S="${WORKDIR}"
 
 pkg_setup() {
-       [ -z "`use sdl``use ggi`" ] \
-               && die "You must have sdl or ggi in your USE variable" \
-               || return 0
+       if use !sdl && use !ggi ; then
+               die "You must have sdl or ggi in your USE variable"
+       fi
+       return 0
 }
 
 src_compile() {
-       local myconf="--disable-heroes-debug `use_enable nls`"
+       local myconf="--disable-heroes-debug $(use_enable nls)"
 
-       if [ `use sdl` ] ; then
+       if use sdl ; then
                myconf="${myconf} --with-sdl --with-sdl-mixer"
        else
                myconf="${myconf} --with-ggi --with-mikmod"