dev-ruby/json: cleanup
authorHans de Graaff <graaff@gentoo.org>
Sun, 3 Nov 2019 07:06:03 +0000 (08:06 +0100)
committerHans de Graaff <graaff@gentoo.org>
Sun, 3 Nov 2019 07:06:03 +0000 (08:06 +0100)
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
dev-ruby/json/json-2.1.0-r1.ebuild [deleted file]

diff --git a/dev-ruby/json/json-2.1.0-r1.ebuild b/dev-ruby/json/json-2.1.0-r1.ebuild
deleted file mode 100644 (file)
index cfac102..0000000
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_GEMSPEC="json.gemspec"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A JSON implementation as a Ruby extension"
-HOMEPAGE="https://github.com/flori/json"
-LICENSE="Ruby"
-
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="2"
-IUSE=""
-
-RDEPEND="${RDEPEND}"
-DEPEND="${DEPEND}
-       dev-util/ragel"
-
-PATCHES=(
-       "${FILESDIR}/${P}-ruby26-1.patch"
-       "${FILESDIR}/${P}-ruby26-2.patch"
-       "${FILESDIR}/${P}-ruby26-3.patch"
-)
-
-ruby_add_bdepend "dev-ruby/rake
-       doc? ( dev-ruby/rdoc )"
-
-all_ruby_prepare() {
-       # Avoid building the extension twice!
-       # And use rdoc instead of sdoc which we don't have packaged
-       # And don't call git to list files. We're using the pregenerated spec anyway.
-       sed -i \
-               -e '/task :test/ s|:compile,||' \
-               -e 's| => :clean||' \
-               -e 's|sdoc|rdoc|' \
-               -e 's|`git ls-files`|""|' \
-               Rakefile || die "rakefile fix failed"
-
-       # Remove hardcoded and broken -O setting.
-       sed -i -e '/^  \(if\|unless\)/,/^  end/ s:^:#:' \
-               -e '/^unless/,/^end/ s:^:#:' ext/json/ext/*/extconf.rb || die
-
-       # Avoid setting gem since it will not be available yet when installing
-       sed -i -e '/gem/ s:^:#:' tests/test_helper.rb || die
-}
-
-each_ruby_configure() {
-       for ext in parser generator ; do
-               ${RUBY} -Cext/json/ext/${ext} extconf.rb || die
-       done
-}
-
-each_ruby_compile() {
-       for ext in parser generator ; do
-               emake V=1 -Cext/json/ext/${ext}
-               cp ext/json/ext/${ext}/${ext}$(get_modname) ext/json/ext/ || die
-       done
-}
-
-each_ruby_test() {
-       for t in pure ext ; do
-               JSON=${T} ${RUBY} -S rake do_test_${t} || die
-       done
-}
-
-each_ruby_install() {
-       each_fakegem_install
-
-       ruby_fakegem_newins ext/json/ext/generator$(get_modname) lib/json/ext/generator$(get_modname)
-       ruby_fakegem_newins ext/json/ext/parser$(get_modname) lib/json/ext/parser$(get_modname)
-}