sys-apps/nix: 1.11.16
authorSergei Trofimovich <slyfox@gentoo.org>
Thu, 21 Dec 2017 07:59:50 +0000 (07:59 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Thu, 21 Dec 2017 08:01:25 +0000 (08:01 +0000)
Package-Manager: Portage-2.3.19, Repoman-2.3.6

sys-apps/nix/Manifest
sys-apps/nix/nix-1.11.16.ebuild [new file with mode: 0644]

index 5e188c003aa5dd78d16ff6df40895035a8ff85bc..216f1c03ae024d5b86566f33d8302b15db3db2e5 100644 (file)
@@ -1,2 +1,3 @@
 DIST nix-1.11.14.tar.xz 632260 BLAKE2B 5ee239aca547a8918c574dbdc6f1276dff1b66f83c89f85c23f242551a6e6784e2bdc4fcfce327395df7628148409ab13954b6eb78710325bc04c370d401ea82 SHA512 48ed17a090a161ad35c8e84652566e527f31586184b8722a5536a6d83eee1e81911b6c4d5f0661f57054db6c47b5d8211f2acf47899fbec72f2c4bf8a5262af5
 DIST nix-1.11.15.tar.xz 632544 BLAKE2B 3624c396c67a7c64e2ba16fd500951e6cf1b6f29f31929793072b5dfcdf1ffe40d5645c58d3967dd82d6c8d0bf6e5e2598a0d8d5fc3f82b22ea279a7854b1aca SHA512 449b3c78b74c776215dfbe9d6d09b96d8c6abf996c69c525073df12d0cffb1a2868890d356fbb52c794e2c6f485018756395625e7b170166f7c6f9e2bdd364d9
+DIST nix-1.11.16.tar.xz 632440 BLAKE2B 0b1966b1445a18616d6ff33e7fa3d1776626872c7cfeb54be4c77b998841db69f1e6aea7638edb21fa67442b953fb1cbaf7752c841d7d21f62dd63885a823834 SHA512 164f728c96fc6609134334e61f674961dfc0f02bd2f5d1d7800d2623fe80d896bfd0b7fba0a723b1bfe23663d4c7cf3e419a7c1992d67e80eb3d6b3bdf60a2a8
diff --git a/sys-apps/nix/nix-1.11.16.ebuild b/sys-apps/nix/nix-1.11.16.ebuild
new file mode 100644 (file)
index 0000000..d4e6165
--- /dev/null
@@ -0,0 +1,134 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic readme.gentoo-r1 user
+
+DESCRIPTION="A purely functional package manager"
+HOMEPAGE="https://nixos.org/nix"
+
+SRC_URI="http://nixos.org/releases/${PN}/${P}/${P}.tar.xz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+etc_profile +gc doc sodium"
+
+RDEPEND="
+       app-arch/bzip2
+       app-arch/xz-utils
+       dev-db/sqlite
+       dev-libs/openssl:0=
+       net-misc/curl
+       sys-libs/libseccomp
+       sys-libs/zlib
+       gc? ( dev-libs/boehm-gc[cxx] )
+       doc? ( dev-libs/libxml2
+               dev-libs/libxslt
+               app-text/docbook-xsl-stylesheets
+       )
+       sodium? ( dev-libs/libsodium )
+       dev-lang/perl:=
+       dev-perl/DBD-SQLite
+       dev-perl/WWW-Curl
+       dev-perl/DBI
+"
+DEPEND="${RDEPEND}
+       >=sys-devel/bison-2.6
+       >=sys-devel/flex-2.5.35
+       virtual/perl-ExtUtils-ParseXS
+"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.11.6-systemd.patch
+       "${FILESDIR}"/${PN}-1.11.6-per-user.patch
+       "${FILESDIR}"/${PN}-1.11.6-respect-CXXFLAGS.patch
+       "${FILESDIR}"/${PN}-1.11.6-respect-LDFLAGS.patch
+)
+
+DISABLE_AUTOFORMATTING=yes
+DOC_CONTENTS=" Quick start user guide on Gentoo:
+
+[as root] enable nix-daemon service:
+       [systemd] # systemctl enable nix-daemon
+       [openrc]  # rc-update add nix-daemon
+[as a user] relogin to get environment and profile update
+[as a user] fetch nixpkgs update:
+       \$ nix-channel --update
+[as a user] install nix packages:
+       \$ nix-env -i mc
+[as a user] configure environment:
+       Somewhere in .bash_profile you might want to set
+       LOCALE_ARCHIVE=\$HOME/.nix-profile/lib/locale/locale-archive
+       but please read https://github.com/NixOS/nixpkgs/issues/21820
+
+Next steps:
+       nix package manager user manual: http://nixos.org/nix/manual/
+"
+
+pkg_setup() {
+       enewgroup nixbld
+       for i in {1..10}; do
+               # we list 'nixbld' twice to
+               # both assign a primary group for user
+               # and add a user to /etc/group
+               enewuser nixbld${i} -1 -1 /var/empty nixbld,nixbld
+       done
+}
+
+src_prepare() {
+       default
+
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               --localstatedir="${EPREFIX}"/nix/var \
+               $(use_enable gc)
+}
+
+src_compile() {
+       local make_vars=(
+               OPTIMIZE=0 # disable hardcoded -O3
+               V=1 # verbose build
+       )
+       emake "${make_vars[@]}"
+}
+
+src_install() {
+       # TODO: emacs highlighter
+       default
+
+       readme.gentoo_create_doc
+
+       # here we use an eager variant of something that
+       # is lazily done by nix-daemon and root nix-env
+
+       # TODO: will need a tweak for prefix
+       keepdir             /nix/store
+       fowners root:nixbld /nix/store
+       fperms 1775         /nix/store
+
+       keepdir             /nix/var/nix/profiles/per-user
+       fperms 1777         /nix/var/nix/profiles/per-user
+
+       # setup directories nix-daemon: /etc/profile.d/nix-daemon.sh
+       keepdir             /nix/var/nix/gcroots/per-user
+       fperms 1777         /nix/var/nix/gcroots/per-user
+
+       newinitd "${FILESDIR}"/nix-daemon.initd nix-daemon
+
+       if ! use etc_profile; then
+               rm "${ED}"/etc/profile.d/nix.sh || die
+               rm "${ED}"/etc/profile.d/nix-daemon.sh || die
+       fi
+}
+
+pkg_postinst() {
+       if ! use etc_profile; then
+               ewarn "${EROOT}etc/profile.d/nix.sh was removed (due to USE=-etc_profile)."
+       fi
+
+       readme.gentoo_print_elog
+}