net-misc/l7-filter-userspace: cleanup old files
authorAndrew Savchenko <bircoph@gentoo.org>
Mon, 4 Nov 2019 18:55:58 +0000 (21:55 +0300)
committerAndrew Savchenko <bircoph@gentoo.org>
Mon, 4 Nov 2019 19:02:57 +0000 (22:02 +0300)
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
net-misc/l7-filter-userspace/Manifest
net-misc/l7-filter-userspace/files/l7-filter-userspace-0.11-arm-ppc-getopt-help-fix.patch [deleted file]
net-misc/l7-filter-userspace/files/l7-filter-userspace-0.11-map-access-threadsafe.patch [deleted file]
net-misc/l7-filter-userspace/files/l7-filter-userspace-0.11-pattern-loading-leak.patch [deleted file]
net-misc/l7-filter-userspace/l7-filter-userspace-0.11.ebuild [deleted file]
net-misc/l7-filter-userspace/l7-filter-userspace-0.12_beta1.ebuild [deleted file]

index da0d7cdb78ab44b8c26118938320e66567bfd5a9..caea7f37f1c054455258f649e52e85d1e3aebfaf 100644 (file)
@@ -1,2 +1 @@
-DIST l7-filter-userspace-0.11.tar.gz 129986 BLAKE2B 2bb5bd6794b01508da1f23dff44a242b17efd10e6f2b484aed34b32ea5ba3d787b2ea7ca8df9c57a1c20133337b4a1ac4ad4e7e400fbe97e044530f12e8673ad SHA512 5362a9e7392afd6dcb40bd9f602bddd34c040dcecbcc4570f56168310bd0e243561a1c946c7e912448518fe30c6bcff866c000b9e026dc96b2f3b47b4299cb81
 DIST l7-filter-userspace-0.12-beta1.tar.gz 130254 BLAKE2B 624f0af8c4acf8ad37b580d1488e6d09a82a01d8b2a77727074506ae9eb5d9c006f3ba79deeb5214a41db682b9bd8c3aa59bd81ff20daefcbf938476c6cc62ef SHA512 9c49b7e951ced6a44f8ee6f3a261ba14b1e3fe44a83e175f7f5a5821616ec8bc2b0a287f10b4485120e7783c9623c34aae2ee1d8997c258cdfb8230c1f87d137
diff --git a/net-misc/l7-filter-userspace/files/l7-filter-userspace-0.11-arm-ppc-getopt-help-fix.patch b/net-misc/l7-filter-userspace/files/l7-filter-userspace-0.11-arm-ppc-getopt-help-fix.patch
deleted file mode 100644 (file)
index 29801ce..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
---- l7-filter-userspace-0.11/l7-filter.cpp.old 2010-07-12 10:43:58.485002456 +0100
-+++ l7-filter-userspace-0.11/l7-filter.cpp     2010-07-12 11:14:38.825001868 +0100
-@@ -186,15 +186,11 @@
-   conffilename = ""; 
-   const char *opts = "f:q:vh?sb:dn:p:m:cz";
--  int done = 0;
--  while(!done)
-+  int c;
-+  while ((c = getopt (argc, argv, opts)) != -1)
-   {
--    char c;
--    switch(c = getopt(argc, argv, opts))
-+    switch(c)
-     {
--      case -1:
--        done = 1;
--        break;
-       case 'f':
-         conffilename = optarg;
-         break;
diff --git a/net-misc/l7-filter-userspace/files/l7-filter-userspace-0.11-map-access-threadsafe.patch b/net-misc/l7-filter-userspace/files/l7-filter-userspace-0.11-map-access-threadsafe.patch
deleted file mode 100644 (file)
index fea0f5b..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
---- l7-filter-userspace-0.11/l7-conntrack.cpp.orig     2009-02-26 21:40:28.000000000 +0000
-+++ l7-filter-userspace-0.11/l7-conntrack.cpp  2010-07-23 13:03:23.000000000 +0100
-@@ -195,11 +195,13 @@
- {
-   nfct_conntrack_free(ct);
-   nfct_close(cth);
-+  pthread_mutex_destroy(&map_mutex);
- }
- l7_conntrack::l7_conntrack(void* l7_classifier_in) 
- {
-   l7_classifier = (l7_classify *)l7_classifier_in;
-+  pthread_mutex_init(&map_mutex, NULL);
-   
-   // Now open a handler that is subscribed to all possible events
-   cth = nfct_open(CONNTRACK, NFCT_ALL_CT_GROUPS);
-@@ -211,19 +213,27 @@
- l7_connection *l7_conntrack::get_l7_connection(const string key) 
- {
--  return l7_connections[key];
-+  l7_connection *conn;
-+  pthread_mutex_lock(&map_mutex);
-+  conn = l7_connections[key];
-+  pthread_mutex_unlock(&map_mutex);
-+  return conn;
- }
- void l7_conntrack::add_l7_connection(l7_connection* connection, 
-                                       const string key) 
- {
-+  pthread_mutex_lock(&map_mutex);
-   l7_connections[key] = connection;
-+  pthread_mutex_unlock(&map_mutex);
- }
- void l7_conntrack::remove_l7_connection(const string key) 
- {
-+  pthread_mutex_lock(&map_mutex);
-   delete l7_connections[key];
-   l7_connections.erase(l7_connections.find(key));
-+  pthread_mutex_unlock(&map_mutex);
- }
- void l7_conntrack::start() 
---- l7-filter-userspace-0.11/l7-conntrack.h.orig       2010-07-23 13:04:49.000000000 +0100
-+++ l7-filter-userspace-0.11/l7-conntrack.h    2010-07-23 13:05:56.000000000 +0100
-@@ -52,6 +52,7 @@
-   l7_map l7_connections;
-   struct nfct_conntrack *ct;
-   struct nfct_handle *cth; // the callback
-+  pthread_mutex_t map_mutex;
-  public:
-   l7_conntrack(void * foo);
diff --git a/net-misc/l7-filter-userspace/files/l7-filter-userspace-0.11-pattern-loading-leak.patch b/net-misc/l7-filter-userspace/files/l7-filter-userspace-0.11-pattern-loading-leak.patch
deleted file mode 100644 (file)
index 835fc8f..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-diff --git a/l7-filter-userspace/trunk/l7-classify.cpp b/l7-filter-userspace/trunk/l7-classify.cpp
-index 8b5b77e..1c80d4d 100644
---- a/l7-filter-userspace/trunk/l7-classify.cpp
-+++ b/l7-filter-userspace/trunk/l7-classify.cpp
-@@ -59,6 +59,7 @@ l7_pattern::l7_pattern(string name, string pattern_string, int eflags,
-     cerr << "error compiling " << name << " -- " << pattern_string << endl;
-     exit(1);
-   }
-+  free(preprocessed);
- }
diff --git a/net-misc/l7-filter-userspace/l7-filter-userspace-0.11.ebuild b/net-misc/l7-filter-userspace/l7-filter-userspace-0.11.ebuild
deleted file mode 100644 (file)
index d5178df..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils autotools
-
-DESCRIPTION="Userspace utilities for layer 7 iptables QoS"
-HOMEPAGE="http://l7-filter.clearfoundation.com/"
-SRC_URI="mirror://sourceforge/l7-filter/${P}.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-SLOT="0"
-DEPEND=">=net-libs/libnetfilter_conntrack-0.0.100
-               net-libs/libnetfilter_queue"
-RDEPEND="net-misc/l7-protocols
-               ${DEPEND}"
-
-src_prepare() {
-       epatch "${FILESDIR}/${P}-map-access-threadsafe.patch"
-       epatch "${FILESDIR}/${P}-arm-ppc-getopt-help-fix.patch"
-       epatch "${FILESDIR}/${P}-libnetfilter_conntrack-0.0.100.patch"
-       epatch "${FILESDIR}/${P}-pattern-loading-leak.patch"
-       eautoreconf
-}
-
-src_install() {
-       emake DESTDIR="${D}" install
-       dodoc README TODO BUGS THANKS AUTHORS
-}
diff --git a/net-misc/l7-filter-userspace/l7-filter-userspace-0.12_beta1.ebuild b/net-misc/l7-filter-userspace/l7-filter-userspace-0.12_beta1.ebuild
deleted file mode 100644 (file)
index 1a02e94..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils versionator
-
-MY_P=${PN}-$(replace_version_separator 2 '-')
-
-DESCRIPTION="Userspace utilities for layer 7 iptables QoS"
-HOMEPAGE="http://l7-filter.clearfoundation.com/"
-SRC_URI="http://download.clearfoundation.com/l7-filter/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE=""
-SLOT="0"
-
-DEPEND=">=net-libs/libnetfilter_conntrack-0.0.100
-       >=net-libs/libnetfilter_queue-1.0.0
-       net-libs/libnfnetlink"
-RDEPEND="${DEPEND}
-       net-misc/l7-protocols"
-
-S=${WORKDIR}/${MY_P}
-
-DOCS=( README TODO BUGS THANKS AUTHORS )
-
-src_prepare() {
-       epatch "${FILESDIR}/${PN}-0.11-libnetfilter_conntrack-0.0.100.patch" \
-               "${FILESDIR}/${PN}-0.11-datatype.patch"
-}