app-shells/tcsh: add patch to fix USE=-nls, bug #689904
authorFabian Groffen <grobian@gentoo.org>
Tue, 16 Jul 2019 09:38:02 +0000 (11:38 +0200)
committerFabian Groffen <grobian@gentoo.org>
Tue, 16 Jul 2019 09:38:15 +0000 (11:38 +0200)
Closes: https://bugs.gentoo.org/689904
Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Package-Manager: Portage-2.3.66, Repoman-2.3.11

app-shells/tcsh/files/tcsh-6.21.00-no-nls.patch [new file with mode: 0644]
app-shells/tcsh/tcsh-6.21.00.ebuild

diff --git a/app-shells/tcsh/files/tcsh-6.21.00-no-nls.patch b/app-shells/tcsh/files/tcsh-6.21.00-no-nls.patch
new file mode 100644 (file)
index 0000000..a01ebfb
--- /dev/null
@@ -0,0 +1,17 @@
+GetCmdChar: fix compilation with --disable-nls
+
+Bug: https://bugs.gentoo.org/689904
+
+--- a/ed.inputl.c
++++ b/ed.inputl.c
+@@ -669,8 +669,8 @@
+ {
+ #ifndef WINNT_NATIVE // We use more than 256 for various extended keys 
+-    wint_t c = ch & CHAR;
++    eChar c = ch & CHAR;
+ #else
+-    wint_t c = ch;
++    eChar c = ch;
+ #endif
+     return c < NT_NUM_KEYS ? CurrentKeyMap[c] : F_INSERT;
+ }
index dadd2ea9de5a869c7227469ed828727da4ab1003..c4e52506794fdfeb4d464f7c864857d2806ad7c4 100644 (file)
@@ -32,6 +32,7 @@ CONFDIR=${WORKDIR}/tcsh-gentoo-patches-r${CONFVER}
 PATCHES=(
        "${FILESDIR}"/${PN}-6.20.00-debian-dircolors.patch # bug #120792
        "${FILESDIR}"/${PN}-6.18.01-aix.patch
+       "${FILESDIR}"/${PN}-6.21.00-no-nls.patch
 )
 
 src_prepare() {