net-voip/telepathy-haze: fix python_check_deps, bug #628492
authorGilles Dartiguelongue <eva@gentoo.org>
Thu, 24 Aug 2017 22:06:18 +0000 (00:06 +0200)
committerGilles Dartiguelongue <eva@gentoo.org>
Thu, 24 Aug 2017 22:47:43 +0000 (00:47 +0200)
Package-Manager: Portage-2.3.8, Repoman-2.3.3

net-voip/telepathy-haze/telepathy-haze-0.8.0-r2.ebuild

index 838d5918129c13609f7475d285799db7f9149ffa..73c85e8f10e999f534f0f4e29fc9024af3ea8432 100644 (file)
@@ -44,9 +44,10 @@ PATCHES=(
 )
 
 python_check_deps() {
-       use test \
-               && { has_version "dev-python/twisted[${PYTHON_USEDEP}]" \
-                       || has_version "dev-python/twisted-words[${PYTHON_USEDEP}]"; }
+       if use test ; then
+               has_version "dev-python/twisted[${PYTHON_USEDEP}]" \
+                       || has_version "dev-python/twisted-words[${PYTHON_USEDEP}]"
+       fi
 }
 
 src_prepare() {