Bugifx release 5.2, with italian translation.
authorDiego Elio Pettenò <flameeyes@gentoo.org>
Mon, 5 Jun 2006 05:50:44 +0000 (05:50 +0000)
committerDiego Elio Pettenò <flameeyes@gentoo.org>
Mon, 5 Jun 2006 05:50:44 +0000 (05:50 +0000)
Package-Manager: portage-2.1_rc4-r1

sys-block/unieject/ChangeLog
sys-block/unieject/files/digest-unieject-5.2 [new file with mode: 0644]
sys-block/unieject/unieject-5.2.ebuild [new file with mode: 0644]

index 5e51370441c1da17c20cb5b7ac650450ee0beda7..11afcb343720a83d9bd3d17a6319a63931f6a8fc 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for sys-block/unieject
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/unieject/ChangeLog,v 1.22 2006/03/30 18:29:19 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/unieject/ChangeLog,v 1.23 2006/06/05 05:50:44 flameeyes Exp $
+
+*unieject-5.2 (05 Jun 2006)
+
+  05 Jun 2006; Diego Pettenò <flameeyes@gentoo.org> -unieject-5.1.ebuild,
+  +unieject-5.2.ebuild:
+  Bugifx release 5.2, with italian translation.
 
   30 Mar 2006; Diego Pettenò <flameeyes@gentoo.org> unieject-5.1.ebuild:
   Add ~x86-fbsd keyword.
diff --git a/sys-block/unieject/files/digest-unieject-5.2 b/sys-block/unieject/files/digest-unieject-5.2
new file mode 100644 (file)
index 0000000..9319bdf
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 3028c259b1f600900cccac2f89f3ed21 unieject-5.2.tar.bz2 301463
+RMD160 61edef4319c2accef9693fdf1143cabd3a2e109a unieject-5.2.tar.bz2 301463
+SHA256 866e72717a162d59e09bcc9d998e5e0347eb22874481e9dcb7af04c9e0dc8bfd unieject-5.2.tar.bz2 301463
diff --git a/sys-block/unieject/unieject-5.2.ebuild b/sys-block/unieject/unieject-5.2.ebuild
new file mode 100644 (file)
index 0000000..345dc13
--- /dev/null
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/unieject/unieject-5.2.ebuild,v 1.1 2006/06/05 05:50:44 flameeyes Exp $
+
+inherit libtool
+
+DESCRIPTION="Multiplatform command to eject and load CD-Rom drives"
+HOMEPAGE="http://dev.gentoo.org/~flameeyes/projects"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="nls"
+
+RDEPEND=">=dev-libs/libcdio-0.75-r1
+       dev-libs/popt
+       >=dev-libs/confuse-2.5
+       nls? ( virtual/libintl )
+       !sys-apps/eject
+       !sys-block/eject-bsd"
+DEPEND="${RDEPEND}
+       nls? ( sys-devel/gettext )
+       sys-apps/sed"
+
+PROVIDE="virtual/eject"
+
+src_unpack() {
+       unpack ${A}
+       cd ${S}
+
+       # libcdio-0.75-r1 in Gentoo is fixed, so no need to ask 0.76 either on
+       # FreeBSD.
+       sed -i -e '/freebsd/s:libcdiomin="0\.76":libcdiomin="0.75":' \
+               ${S}/configure
+
+       elibtoolize
+}
+
+src_compile() {
+       econf \
+               $(use_enable nls) \
+               --enable-lock-workaround \
+               --disable-dependency-tracking \
+               --disable-doc \
+               || die "econf failed"
+       emake || die "emake failed"
+}
+
+src_install() {
+       make DESTDIR="${D}" install
+       dodoc README ChangeLog NEWS AUTHORS unieject.conf.sample
+
+       # Symlink to eject to provide a good virtual/eject
+       dosym unieject.1.gz /usr/share/man/man1/eject.1.gz
+       dosym unieject /usr/bin/eject
+}