x11-misc/bbrun: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Tue, 24 Dec 2019 17:40:14 +0000 (18:40 +0100)
committerDavid Seifert <soap@gentoo.org>
Tue, 24 Dec 2019 17:40:14 +0000 (18:40 +0100)
Package-Manager: Portage-2.3.82, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
x11-misc/bbrun/bbrun-1.6-r1.ebuild
x11-misc/bbrun/files/bbrun-1.6-list.patch
x11-misc/bbrun/files/bbrun-1.6-makefile.patch

index 07fa033e05dc2f90562d9d129f97d71b8f0034e9..f9bd99cef70bafbe97400a4e28d52c70f8f6e9cc 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=7
 
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
 
 DESCRIPTION="blackbox program execution dialog box"
 HOMEPAGE="http://www.darkops.net/bbrun"
@@ -12,17 +12,21 @@ SRC_URI="http://www.darkops.net/${PN}/${P}.tar.gz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="amd64 ppc x86"
-IUSE=""
 
-RDEPEND="x11-libs/gtk+:2"
-DEPEND="${RDEPEND}
-       x11-libs/libXpm
+RDEPEND="
+       dev-libs/glib:2
+       x11-libs/gtk+:2
+       x11-libs/libX11
+       x11-libs/libXext
+       x11-libs/libXpm"
+DEPEND="${RDEPEND}"
+BDEPEND="
        virtual/pkgconfig"
 
-src_prepare() {
-       epatch "${FILESDIR}"/${P}-makefile.patch
-       epatch "${FILESDIR}"/${P}-list.patch
-}
+PATCHES=(
+       "${FILESDIR}"/${P}-makefile.patch
+       "${FILESDIR}"/${P}-list.patch
+)
 
 src_compile() {
        emake -C ${PN} CC="$(tc-getCC)"
index 654b4f68144e454f330cb3213515dcc84f54f278..d487efc3d5a78597af849a345e94594a881391f1 100644 (file)
@@ -1,6 +1,5 @@
-diff -Naur wmgeneral.orig/list.c wmgeneral/list.c
---- wmgeneral.orig/list.c      2002-02-05 18:36:19.000000000 +0100
-+++ wmgeneral/list.c   2016-01-04 12:54:39.666670005 +0100
+--- a/wmgeneral/list.c
++++ b/wmgeneral/list.c
 @@ -38,7 +38,7 @@
  
  /* Return a cons cell produced from (head . tail) */
@@ -82,9 +81,8 @@ diff -Naur wmgeneral.orig/list.c wmgeneral/list.c
  list_mapcar(LinkedList* list, void(*function)(void*))
  {
    while(list)
-diff -Naur wmgeneral.orig/list.h wmgeneral/list.h
---- wmgeneral.orig/list.h      2002-02-05 18:36:19.000000000 +0100
-+++ wmgeneral/list.h   2016-01-04 12:54:39.666670005 +0100
+--- a/wmgeneral/list.h
++++ b/wmgeneral/list.h
 @@ -29,31 +29,25 @@
  #ifndef __LIST_H_
  #define __LIST_H_
index cf89b96df6f35cae6c81dca0487465ac88a784ec..21e855746d094b5885caad1483c1ff9343774de1 100644 (file)
@@ -2,8 +2,8 @@ Respect {C,LD}FLAGS, fix underlinking
 
 http://bugs.gentoo.org/367853
 
---- bbrun/Makefile
-+++ bbrun/Makefile
+--- a/bbrun/Makefile
++++ b/bbrun/Makefile
 @@ -1,7 +1,7 @@
  CC     = gcc
  LIBDIR = -L/usr/lib -L/usr/X11R6/lib