sci-mathematics/rstudio: Fix building with boost 1.72
authorDavid Seifert <soap@gentoo.org>
Fri, 20 Dec 2019 17:53:44 +0000 (18:53 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 20 Dec 2019 17:53:44 +0000 (18:53 +0100)
Closes: https://bugs.gentoo.org/703124
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
sci-mathematics/rstudio/files/rstudio-1.0.44-systemd.patch
sci-mathematics/rstudio/files/rstudio-1.2.1335-boost-1.72-filesystem.patch [new file with mode: 0644]
sci-mathematics/rstudio/rstudio-1.2.1335.ebuild

index 7eafd4386abdc5c9fbce80a9919fc174566ab862..56601de5341c93854d290e1dd8d7f52b73fd9ae2 100644 (file)
@@ -1,7 +1,7 @@
---- rstudio-1.0.44-orig/src/cpp/server/CMakeLists.txt  2016-10-19 08:32:41.000000000 +1100
-+++ rstudio-1.0.44/src/cpp/server/CMakeLists.txt       2016-12-02 11:11:45.259050839 +1100
-@@ -203,17 +203,12 @@
-            DESTINATION ${RSERVER_UPSTART_DIR})
+--- a/src/cpp/server/CMakeLists.txt
++++ b/src/cpp/server/CMakeLists.txt
+@@ -232,17 +232,12 @@
+            DESTINATION ${DISTRO_SHARE}/${RSERVER_UPSTART_DIR})
  
      # install configured systemd profile
 -   set(RSERVER_SYSTEMD_DIR "extras/systemd")
diff --git a/sci-mathematics/rstudio/files/rstudio-1.2.1335-boost-1.72-filesystem.patch b/sci-mathematics/rstudio/files/rstudio-1.2.1335-boost-1.72-filesystem.patch
new file mode 100644 (file)
index 0000000..b2c4d23
--- /dev/null
@@ -0,0 +1,31 @@
+From a11d0454e5fe9c50005a03b9d9de84355df5c7fd Mon Sep 17 00:00:00 2001
+From: Kevin Ushey <kevinushey@gmail.com>
+Date: Fri, 15 Nov 2019 14:54:02 -0800
+Subject: [PATCH] avoid use of deprecated APIs
+
+---
+ src/cpp/core/FilePath.cpp | 4 +---
+ 1 file changed, 1 insertion(+), 3 deletions(-)
+
+diff --git a/src/cpp/shared_core/FilePath.cpp b/src/cpp/shared_core/FilePath.cpp
+index 088366a9d6..495289e7fc 100644
+--- a/src/cpp/core/FilePath.cpp
++++ b/src/cpp/core/FilePath.cpp
+@@ -22,8 +22,6 @@
+ #include <windows.h>
+ #endif
+-#define BOOST_FILESYSTEM_NO_DEPRECATED
+-
+ #define BOOST_NO_CXX11_SCOPED_ENUMS
+ #include <boost/filesystem.hpp>
+ #undef BOOST_NO_CXX11_SCOPED_ENUMS
+@@ -1032,7 +1030,7 @@
+       {
+          // NOTE: The path gets round-tripped through toString/fromString, would
+          //   be nice to have a direct constructor
+-         if (!iterationFunction(itr.level(),
++         if (!iterationFunction(itr.depth(),
+                                 FilePath(BOOST_FS_PATH2STR(itr->path()))))
+          {
+             // end the iteration if requested
index 9d0dfd64d7d1f89b6dee5ea417c8b21fc314a000..2ba27bd51487cd744173fb60eb8fdd54c9642cc1 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit eutils user cmake-utils gnome2-utils pam xdg-utils java-pkg-2 pax-utils qmake-utils
+inherit eutils user cmake-utils gnome2-utils pam xdg-utils java-pkg-2 pax-utils qmake-utils vcs-clean
 
 # TODO
 # * package gin and gwt
@@ -92,16 +92,17 @@ DEPEND="${RDEPEND}
 #      test? ( dev-java/junit:4 )
 
 PATCHES=(
-               "${FILESDIR}/${PN}-1.2.1335-prefs.patch"
-               "${FILESDIR}/${PN}-1.2.1335-paths.patch"
-               "${FILESDIR}/${PN}-1.2.1335-pandoc.patch"
-               "${FILESDIR}/${PN}-1.2.1335-linker_flags.patch"
-               "${FILESDIR}/${PN}-1.2.1335-qtsingleapplication.patch"
-               "${FILESDIR}/${PN}-1.0.44-systemd.patch"
-               "${FILESDIR}/${PN}-1.2.1335-core.patch"
-               "${FILESDIR}/${PN}-1.2.1335-fix-ptr-int-compare.patch"
-               "${FILESDIR}/${PN}-1.2.1335-boost-1.70.0_p1.patch"
-               "${FILESDIR}/${PN}-1.2.1335-boost-1.70.0_p2.patch"
+       "${FILESDIR}"/${PN}-1.2.1335-prefs.patch
+       "${FILESDIR}"/${PN}-1.2.1335-paths.patch
+       "${FILESDIR}"/${PN}-1.2.1335-pandoc.patch
+       "${FILESDIR}"/${PN}-1.2.1335-linker_flags.patch
+       "${FILESDIR}"/${PN}-1.2.1335-qtsingleapplication.patch
+       "${FILESDIR}"/${PN}-1.0.44-systemd.patch
+       "${FILESDIR}"/${PN}-1.2.1335-core.patch
+       "${FILESDIR}"/${PN}-1.2.1335-fix-ptr-int-compare.patch
+       "${FILESDIR}"/${PN}-1.2.1335-boost-1.70.0_p1.patch
+       "${FILESDIR}"/${PN}-1.2.1335-boost-1.70.0_p2.patch
+       "${FILESDIR}"/${PN}-1.2.1335-boost-1.72-filesystem.patch
 )
 
 src_unpack() {