dev-python/numpy-python2: fix install with recent distutils-r1 change
authorMike Gilbert <floppym@gentoo.org>
Thu, 16 Apr 2020 17:46:30 +0000 (13:46 -0400)
committerMike Gilbert <floppym@gentoo.org>
Thu, 16 Apr 2020 17:46:30 +0000 (13:46 -0400)
Bug: https://bugs.gentoo.org/717706
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
dev-python/numpy-python2/files/numpy-1.16.5-setup.py-install-skip-build-fails.patch [new file with mode: 0644]
dev-python/numpy-python2/numpy-python2-1.16.5.ebuild

diff --git a/dev-python/numpy-python2/files/numpy-1.16.5-setup.py-install-skip-build-fails.patch b/dev-python/numpy-python2/files/numpy-1.16.5-setup.py-install-skip-build-fails.patch
new file mode 100644 (file)
index 0000000..aa141de
--- /dev/null
@@ -0,0 +1,23 @@
+From b8e741c66f71071c3406e592e1537570731bcb35 Mon Sep 17 00:00:00 2001
+From: mattip <matti.picus@gmail.com>
+Date: Sun, 26 May 2019 08:55:53 +0300
+Subject: [PATCH] BUG: setup.py install --skip-build fails
+
+---
+ numpy/distutils/command/install_clib.py | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/numpy/distutils/command/install_clib.py b/numpy/distutils/command/install_clib.py
+index 662aa00bda9..6a73f7e3308 100644
+--- a/numpy/distutils/command/install_clib.py
++++ b/numpy/distutils/command/install_clib.py
+@@ -19,6 +19,9 @@ def finalize_options(self):
+     def run (self):
+         build_clib_cmd = get_cmd("build_clib")
++        if not build_clib_cmd.build_clib:
++            # can happen if the user specified `--skip-build`
++            build_clib_cmd.finalize_options()
+         build_dir = build_clib_cmd.build_clib
+         # We need the compiler to get the library name -> filename association
index d98d8624653984758d0683488babdd9f98fb8af0..b6c8b4fa6cf06362a36aa8c0817ad4af5fe3434f 100644 (file)
@@ -50,6 +50,7 @@ S="${WORKDIR}/${MY_PN}-${PV}"
 
 PATCHES=(
        "${FILESDIR}"/${MY_PN}-1.15.4-no-hardcode-blas.patch
+       "${FILESDIR}"/numpy-1.16.5-setup.py-install-skip-build-fails.patch
 )
 
 src_unpack() {