Bump to version 0.44; bug 156322; thanks to Axel Dyks
authorCharlie Shepherd <masterdriverz@gentoo.org>
Wed, 13 Dec 2006 22:57:03 +0000 (22:57 +0000)
committerCharlie Shepherd <masterdriverz@gentoo.org>
Wed, 13 Dec 2006 22:57:03 +0000 (22:57 +0000)
Package-Manager: portage-2.1.2_rc3-r1

net-ftp/tftp-hpa/ChangeLog
net-ftp/tftp-hpa/files/digest-tftp-hpa-0.44 [new file with mode: 0644]
net-ftp/tftp-hpa/files/in.tftpd.confd-0.44 [new file with mode: 0644]
net-ftp/tftp-hpa/tftp-hpa-0.44.ebuild [new file with mode: 0644]

index a9b4b8209372001c3d9ab24d5b0cb015205d32ea..3a8fc0ce55424b9f2ee4b97e96059028e59a678a 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for net-ftp/tftp-hpa
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/tftp-hpa/ChangeLog,v 1.20 2006/11/19 19:05:13 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/tftp-hpa/ChangeLog,v 1.21 2006/12/13 22:57:03 masterdriverz Exp $
+
+*tftp-hpa-0.44 (13 Dec 2006)
+
+  13 Dec 2006; Charlie Shepherd <masterdriverz@gentoo.org>
+  -files/in.tftpd.confd-0.42, +files/in.tftpd.confd-0.44,
+  -tftp-hpa-0.42.ebuild, -tftp-hpa-0.42-r1.ebuild, +tftp-hpa-0.44.ebuild:
+  Bump to version 0.44; bug 156322; thanks to Axel Dyks
 
   19 Nov 2006; Diego Pettenò <flameeyes@gentoo.org> +metadata.xml,
   tftp-hpa-0.42-r1.ebuild:
diff --git a/net-ftp/tftp-hpa/files/digest-tftp-hpa-0.44 b/net-ftp/tftp-hpa/files/digest-tftp-hpa-0.44
new file mode 100644 (file)
index 0000000..0032052
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 185b5ac2faff81e52787ffd7aaed2509 tftp-hpa-0.44.tar.bz2 83122
+RMD160 1d7516c09298f344e7b2d4c28a7c550acef5ab98 tftp-hpa-0.44.tar.bz2 83122
+SHA256 15f6a417119cc0df3c05eac8d430ac64073b5ae9c0afb0d3ac002bed45b69d73 tftp-hpa-0.44.tar.bz2 83122
diff --git a/net-ftp/tftp-hpa/files/in.tftpd.confd-0.44 b/net-ftp/tftp-hpa/files/in.tftpd.confd-0.44
new file mode 100644 (file)
index 0000000..14e8d14
--- /dev/null
@@ -0,0 +1,15 @@
+# /etc/init.d/in.tftpd
+
+# Path to server files from
+# Depending on your application you may have to change this.
+# This is commented out to force you to look at the file!
+#INTFTPD_PATH="/var/tftp/"
+#INTFTPD_PATH="/tftpboot/"
+#INTFTPD_PATH="/tftproot/"
+
+# For more options, see in.tftpd(8)
+# -R 4096:32767 solves problems with ARC firmware, and obsoletes
+# the /proc/sys/net/ipv4/ip_local_port_range hack.
+# -s causes $INTFTPD_PATH to be the root of the TFTP tree.
+# -l is passed by the init script in addition to these options.
+INTFTPD_OPTS="-R 4096:32767 -s ${INTFTPD_PATH}"
diff --git a/net-ftp/tftp-hpa/tftp-hpa-0.44.ebuild b/net-ftp/tftp-hpa/tftp-hpa-0.44.ebuild
new file mode 100644 (file)
index 0000000..fc9c6c9
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/tftp-hpa/tftp-hpa-0.44.ebuild,v 1.1 2006/12/13 22:57:03 masterdriverz Exp $
+
+DESCRIPTION="port of the OpenBSD TFTP server"
+HOMEPAGE="http://www.kernel.org/pub/software/network/tftp/"
+SRC_URI="mirror://kernel/software/network/tftp/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd"
+IUSE="readline selinux tcpd"
+
+DEPEND="readline? ( sys-libs/readline )
+       tcpd? ( sys-apps/tcp-wrappers )
+       selinux? ( sec-policy/selinux-tftpd )
+       !virtual/tftp"
+PROVIDE="virtual/tftp"
+
+src_compile() {
+       econf \
+               $(use_with tcpd tcpwrappers) \
+               $(use_with readline) \
+               || die
+       emake || die
+}
+
+src_install() {
+       make INSTALLROOT="${D}" install || die
+       dodoc README* CHANGES tftpd/sample.rules
+
+       # iputils installs this
+       rm -f "${D}"/usr/share/man/man8/tftpd.8
+
+       newconfd "${FILESDIR}"/in.tftpd.confd-${PV} in.tftpd
+       newinitd "${FILESDIR}"/in.tftpd.rc6 in.tftpd
+}
+
+pkg_postinst() {
+       ewarn "After installation, please ensure you look at"
+       ewarn "/etc/conf.d/in.tftpd and set the correct path"
+       ewarn "for your application."
+}