acct-user/minetest: Add home directory
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>
Mon, 9 Mar 2020 01:03:38 +0000 (21:03 -0400)
committerJoonas Niilola <juippis@gentoo.org>
Mon, 9 Mar 2020 05:55:10 +0000 (07:55 +0200)
Minetest requires a home directory to store user data. This patch adds
/var/lib/minetest as the default home directory for the minetest user.

Bug: https://bugs.gentoo.org/709530
Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/14890
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
acct-user/minetest/minetest-1.ebuild [new file with mode: 0644]

diff --git a/acct-user/minetest/minetest-1.ebuild b/acct-user/minetest/minetest-1.ebuild
new file mode 100644 (file)
index 0000000..7289783
--- /dev/null
@@ -0,0 +1,14 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit acct-user
+
+DESCRIPTION="A user for the Minetest server"
+
+ACCT_USER_GROUPS=( "minetest" )
+ACCT_USER_ID="480"
+ACCT_USER_HOME="/var/lib/minetest"
+
+acct-user_add_deps