dev-db/postgis: Live ebuild parity to 2.5.2
authorAaron W. Swenson <titanofold@gentoo.org>
Tue, 18 Jun 2019 10:54:26 +0000 (06:54 -0400)
committerAaron W. Swenson <titanofold@gentoo.org>
Tue, 18 Jun 2019 10:54:41 +0000 (06:54 -0400)
Package-Manager: Portage-2.3.62, Repoman-2.3.11
Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
dev-db/postgis/postgis-9999.ebuild

index 156d4d9bc7dba820183d74b75591df1e2d4263e9..ef406c8c690c2cfc8f9e60eb38d6dfbb92af3df3 100644 (file)
@@ -18,16 +18,18 @@ HOMEPAGE="http://postgis.net"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS=""
-IUSE="doc gtk static-libs test"
+IUSE="address-standardizer doc gtk static-libs mapbox test topology"
 
 RDEPEND="
        ${POSTGRES_DEP}
        dev-libs/json-c:=
        dev-libs/libxml2:2
-       >=sci-libs/geos-3.4.2
+       >=sci-libs/geos-3.5.0
        >=sci-libs/proj-4.6.0
-       >=sci-libs/gdal-1.10.0:=
+       >=sci-libs/gdal-1.10.0
+       address-standardizer? ( dev-libs/libpcre )
        gtk? ( x11-libs/gtk+:2 )
+       mapbox? ( dev-libs/protobuf )
 "
 
 DEPEND="${RDEPEND}
@@ -46,8 +48,6 @@ REQUIRED_USE="test? ( doc )"
 # Needs a running psql instance, doesn't work out of the box
 RESTRICT="test"
 
-MAKEOPTS+=' -j1'
-
 src_prepare() {
        source "${S}"/Version.config
        export PGIS="${POSTGIS_MAJOR_VERSION}.${POSTGIS_MINOR_VERSION}"
@@ -57,6 +57,7 @@ src_prepare() {
        # *FLAGS settings.
        export QA_FLAGS_IGNORED="usr/lib(64)?/(rt)?postgis-${PGIS}\.so"
 
+       eapply "${FILESDIR}/${PN}-2.2.0-arflags.patch"
        eapply_user
 
        local AT_M4DIR="macros"
@@ -66,7 +67,13 @@ src_prepare() {
 
 src_configure() {
        local myargs=""
-       use gtk && myargs+=" --with-gui"
+
+       use gtk                  && myargs+=" --with-gui"
+
+       use address-standardizer || myargs+=" --without-address-standardizer"
+       use mapbox               || myargs+=" --without-protobuf"
+       use topology             || myargs+=" --without-topology"
+
        postgres-multi_foreach econf ${myargs}
 }