app-crypt/tc-play: add sysmacros.h
authorAlon Bar-Lev <alonbl@gentoo.org>
Sat, 8 Apr 2017 17:33:05 +0000 (20:33 +0300)
committerAlon Bar-Lev <alonbl@gentoo.org>
Sat, 8 Apr 2017 17:33:23 +0000 (20:33 +0300)
Bug: 579924

Package-Manager: Portage-2.3.3, Repoman-2.3.1

app-crypt/tc-play/files/tc-play-2.0-build.patch [new file with mode: 0644]
app-crypt/tc-play/tc-play-2.0-r1.ebuild

diff --git a/app-crypt/tc-play/files/tc-play-2.0-build.patch b/app-crypt/tc-play/files/tc-play-2.0-build.patch
new file mode 100644 (file)
index 0000000..0385f33
--- /dev/null
@@ -0,0 +1,27 @@
+From 3f9235841ba4494962b3c7dafcd16fd3ff5f6575 Mon Sep 17 00:00:00 2001
+From: Alon Bar-Lev <alon.barlev@gmail.com>
+Date: Sat, 8 Apr 2017 20:27:17 +0300
+Subject: [PATCH] build: include sys/sysmacros.h for recent glibc
+
+https://sourceware.org/ml/libc-alpha/2015-11/msg00253.html
+
+Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
+---
+ tcplay.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/tcplay.c b/tcplay.c
+index cd882cf..a6d4655 100644
+--- a/tcplay.c
++++ b/tcplay.c
+@@ -47,6 +47,7 @@
+ #if defined(__linux__)
+ #include <libdevmapper.h>
+ #include <uuid/uuid.h>
++#include <sys/sysmacros.h>
+ #elif defined(__DragonFly__)
+ #include <libdm.h>
+ #include <uuid.h>
+-- 
+2.10.2
+
index 043d93a7a769c576e33bd7632ddb0e86cac30467..16df65d19d063c8b3eb8cd9fa2a0e9d5a6c069eb 100644 (file)
@@ -30,6 +30,10 @@ DOCS=(
        README.md
 )
 
+PATCHES=(
+       "${FILESDIR}/${P}-build.patch"
+)
+
 pkg_setup() {
        local backend="openssl"
        use gnutls && local backend="gcrypt"