dev-ml/csv: Bump to 1.6
authorAlexis Ballier <aballier@gentoo.org>
Mon, 27 Feb 2017 13:10:13 +0000 (14:10 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 27 Feb 2017 13:48:28 +0000 (14:48 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-ml/csv/Manifest
dev-ml/csv/csv-1.6.ebuild [new file with mode: 0644]
dev-ml/csv/metadata.xml

index c8d5b456589b82d7246e7025a38a82570613adf5..2723145ddfb1bc1f05df52b6d1f0bba184cbd2dd 100644 (file)
@@ -1 +1,2 @@
 DIST csv-1.5.tar.gz 83642 SHA256 f6307634e5f5fe3d64b90fdf8841b3f50dac80ed45b40d390ee44490c62bf58f SHA512 1c8af0ce8abd8a5710115c194eee34928399964447309ee974665cf427396def42bca4f983904bfec706f7944aea419a87bf54bc6c379cb8b7372be801be4126 WHIRLPOOL fe39114b74cb12b382da64307b8253297614f537ef4309cdcec58e9ec68ff49791d6ef90b4870200f24f6726471ceb925d0a79336853c27769af07413a3c373d
+DIST csv-1.6.tar.gz 98194 SHA256 f217f00a397aa79bcd3f1a657a04cb46d08c7d00f4c3836467dad83d08ea6767 SHA512 689dae2dd57ec914ca1dd5e3d34ebd352aabb7d5da8933aa6c6fc9c6ec84dc538d1df8a1c46f3e172ab09e5917e9158be76afb2423ec8a92eef489ac5dfd5175 WHIRLPOOL 7a9c6cbb33866e6d2e694e1d19ff8c5e9cdb5a5ad4ee2bc7252007a76a22863dda4a34bbaa45579e6487a6b25e5b8afe44e40a067af835d3aca59dac491acd20
diff --git a/dev-ml/csv/csv-1.6.ebuild b/dev-ml/csv/csv-1.6.ebuild
new file mode 100644 (file)
index 0000000..a725347
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="A pure OCaml library to read and write CSV files"
+HOMEPAGE="https://github.com/Chris00/ocaml-csv"
+SRC_URI="https://github.com/Chris00/ocaml-csv/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+lwt"
+
+DEPEND="lwt? ( dev-ml/lwt:= )"
+RDEPEND="${DEPEND}"
+
+DOCS=( "README.txt" "AUTHORS.txt" )
+
+src_configure() {
+       oasis_configure_opts="$(use_enable lwt)" \
+               oasis_src_configure
+}
index 4f4cfaf9927769f2ef952a7a1accc41c84c9574c..2aa54c8c05721c6234b20fea400ed9317f2f2e59 100644 (file)
@@ -8,4 +8,7 @@
        <upstream>
                <remote-id type="github">Chris00/ocaml-csv</remote-id>
        </upstream>
+    <use>
+               <flag name="lwt">Enables the Lwt-based library for asynchronous operations.</flag>
+       </use>
 </pkgmetadata>