app-forensics/galleta: Port to EAPI 6
authorDavid Seifert <soap@gentoo.org>
Fri, 29 Dec 2017 22:18:15 +0000 (23:18 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 29 Dec 2017 22:33:07 +0000 (23:33 +0100)
Package-Manager: Portage-2.3.19, Repoman-2.3.6

app-forensics/galleta/files/galleta-20040505_p1-Wimplicit-function-declaration.patch [new file with mode: 0644]
app-forensics/galleta/files/galleta-20040505_p1-fix-build-system.patch [new file with mode: 0644]
app-forensics/galleta/galleta-20040505_p1.ebuild

diff --git a/app-forensics/galleta/files/galleta-20040505_p1-Wimplicit-function-declaration.patch b/app-forensics/galleta/files/galleta-20040505_p1-Wimplicit-function-declaration.patch
new file mode 100644 (file)
index 0000000..396739d
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/galleta.c
++++ b/galleta.c
+@@ -35,6 +35,8 @@
+ #include <stdio.h>
+ #include <time.h>
+ #include <math.h>
++#include <stdlib.h>
++#include <string.h>
+ #define STRSIZE               1000
diff --git a/app-forensics/galleta/files/galleta-20040505_p1-fix-build-system.patch b/app-forensics/galleta/files/galleta-20040505_p1-fix-build-system.patch
new file mode 100644 (file)
index 0000000..125643c
--- /dev/null
@@ -0,0 +1,12 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,6 @@
+-all: install
++LDLIBS += -lm 
+-install:  galleta.c
+-      gcc -o galleta galleta.c -lm -lc;cp galleta ../bin
++all: galleta
+ installwin:  galleta.c
+       gcc -DCYGWIN -o galleta.exe galleta.c -lm -lc;cp galleta.exe ../bin
index 890ad5ab0d3064b89cc904898a38442e158f41a0..9192b6bdb8cb78d2003210a613542a5fe93db3f2 100644 (file)
@@ -1,25 +1,32 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
+EAPI=6
+
 inherit toolchain-funcs
 
 MY_P=${PN}_${PV/_p/_}
+
 DESCRIPTION="IE Cookie Parser"
 HOMEPAGE="https://sourceforge.net/projects/odessa/"
 SRC_URI="mirror://sourceforge/odessa/${MY_P}.tar.gz"
+
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="~amd64 ~ppc x86"
 IUSE=""
 
-S=${WORKDIR}/${MY_P}
+S=${WORKDIR}/${MY_P}/src
+PATCHES=(
+       "${FILESDIR}"/${P}-fix-build-system.patch
+       "${FILESDIR}"/${P}-Wimplicit-function-declaration.patch
+)
 
-src_compile() {
-       cd src
-       $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o galleta galleta.c -lm -lc || die "failed to compile"
+src_configure() {
+       tc-export CC
 }
 
 src_install() {
-       dodoc Readme.txt
-       dobin src/galleta
+       dobin ${PN}
+       dodoc ../{CHANGES,Readme.txt}
 }