Version bump.
authorTim Harder <radhermit@gentoo.org>
Fri, 21 Oct 2011 06:50:20 +0000 (06:50 +0000)
committerTim Harder <radhermit@gentoo.org>
Fri, 21 Oct 2011 06:50:20 +0000 (06:50 +0000)
Package-Manager: portage-2.2.0_alpha69/cvs/Linux x86_64

media-sound/abcm2ps/ChangeLog
media-sound/abcm2ps/abcm2ps-6.5.2.ebuild [new file with mode: 0644]

index 4121b58dff4b8a419247e5858cca0e6541dff5b5..43c85b053e49f6b06766bb3c1c123ebb4f493fd3 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for media-sound/abcm2ps
 # Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/abcm2ps/ChangeLog,v 1.26 2011/10/07 08:57:13 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/abcm2ps/ChangeLog,v 1.27 2011/10/21 06:50:20 radhermit Exp $
+
+*abcm2ps-6.5.2 (21 Oct 2011)
+
+  21 Oct 2011; Tim Harder <radhermit@gentoo.org> +abcm2ps-6.5.2.ebuild:
+  Version bump.
 
   07 Oct 2011; Tim Harder <radhermit@gentoo.org> -abcm2ps-6.4.3.ebuild,
   -abcm2ps-6.4.4.ebuild, -abcm2ps-6.4.6.ebuild:
diff --git a/media-sound/abcm2ps/abcm2ps-6.5.2.ebuild b/media-sound/abcm2ps/abcm2ps-6.5.2.ebuild
new file mode 100644 (file)
index 0000000..39c619e
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/abcm2ps/abcm2ps-6.5.2.ebuild,v 1.1 2011/10/21 06:50:20 radhermit Exp $
+
+EAPI=4
+
+DESCRIPTION="A program to convert abc files to Postscript files"
+HOMEPAGE="http://moinejf.free.fr/"
+SRC_URI="http://moinejf.free.fr/${P}.tar.gz
+       http://moinejf.free.fr/transpose_abc.pl"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="examples"
+
+src_prepare() {
+       sed -i -e '/LDFLAGS/s:=.*:= @LDFLAGS@:' Makefile.in || die
+}
+
+src_configure() {
+       econf \
+               --enable-a4 \
+               --enable-deco-is-roll
+}
+
+src_install() {
+       dobin abcm2ps
+
+       insinto /usr/share/${PN}
+       doins *.fmt
+
+       dodoc Changes README *.txt
+
+       if use examples ; then
+               docinto examples
+               dodoc *.{abc,eps}
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
+
+       docinto contrib
+       dodoc "${DISTDIR}"/transpose_abc.pl
+}