x11-plugins/wmbio: fix build with -fno-common
authorBernard Cafarelli <voyageur@gentoo.org>
Sun, 8 Mar 2020 11:18:38 +0000 (12:18 +0100)
committerBernard Cafarelli <voyageur@gentoo.org>
Sun, 8 Mar 2020 11:27:31 +0000 (12:27 +0100)
Closes: https://bugs.gentoo.org/707180
Package-Manager: Portage-2.3.92, Repoman-2.3.20
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
x11-plugins/wmbio/files/wmbio-1.02-fno-common.patch [new file with mode: 0644]
x11-plugins/wmbio/wmbio-1.02.ebuild

diff --git a/x11-plugins/wmbio/files/wmbio-1.02-fno-common.patch b/x11-plugins/wmbio/files/wmbio-1.02-fno-common.patch
new file mode 100644 (file)
index 0000000..ce53876
--- /dev/null
@@ -0,0 +1,26 @@
+diff -Naur src.orig/wmbio.c src/wmbio.c
+--- src.orig/wmbio.c   2004-01-21 13:58:12.000000000 +0100
++++ src/wmbio.c        2020-03-08 12:13:32.177944932 +0100
+@@ -78,6 +78,8 @@
+ struct tm *local;  // for the local time
+ time_t tempo;
++Display               *display;
++Window          Root, iconwin, win;
+ /* MAIN */
+ int    main (int argc, char *argv[]);
+diff -Naur src.orig/wmgeneral.h src/wmgeneral.h
+--- src.orig/wmgeneral.h       2002-04-27 16:02:09.000000000 +0200
++++ src/wmgeneral.h    2020-03-08 12:13:24.853941688 +0100
+@@ -24,8 +24,8 @@
+ } XpmIcon;
+-Display               *display;
+-Window          Root, iconwin, win;
++extern Display                *display;
++extern Window          Root, iconwin, win;
+ void AddMouseRegion(int index, int left, int top, int right, int bottom);
index 6f9afadd6ebfc1f17aa67922f44ebc26f3aef521..d2d2e7ccc5fbe29baf718591dd86f123fd1c1d1c 100644 (file)
@@ -18,15 +18,15 @@ RDEPEND="x11-libs/libX11
 DEPEND="${RDEPEND}
        x11-base/xorg-proto"
 
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
 S=${WORKDIR}/${P}/src
 
 src_prepare() {
        default
        # Honour Gentoo CFLAGS
-       sed -i "s/-g -O2/\$(CFLAGS)/" Makefile || die "sed for CFLAGS failed"
-
+       sed -i "s/-g -O2/\$(CFLAGS)/" Makefile || die
        # Honour Gentoo LDFLAGS
-       sed -i "s/-o wmbio/\$(LDFLAGS) -o wmbio/" Makefile || die "sed for LDFLAGS failed"
+       sed -i "s/-o wmbio/\$(LDFLAGS) -o wmbio/" Makefile || die
 }
 
 src_install() {