app-forensics/quickfuzz: tweak for ghc-8.0.2
authorSergei Trofimovich <slyfox@gentoo.org>
Thu, 16 Feb 2017 21:47:26 +0000 (21:47 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Thu, 16 Feb 2017 21:57:12 +0000 (21:57 +0000)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

app-forensics/quickfuzz/files/quickfuzz-0.1_p20160920-directory-1.3.patch [new file with mode: 0644]
app-forensics/quickfuzz/files/quickfuzz-0.1_p20160920-ghc-8.0.2_rc1.patch [new file with mode: 0644]
app-forensics/quickfuzz/quickfuzz-0.1_p20160920.ebuild

diff --git a/app-forensics/quickfuzz/files/quickfuzz-0.1_p20160920-directory-1.3.patch b/app-forensics/quickfuzz/files/quickfuzz-0.1_p20160920-directory-1.3.patch
new file mode 100644 (file)
index 0000000..34e9208
--- /dev/null
@@ -0,0 +1,9 @@
+diff --git a/src/Check.hs b/src/Check.hs
+index b38a56a..246bf24 100644
+--- a/src/Check.hs
++++ b/src/Check.hs
+@@ -23,3 +23,3 @@ import System.Posix.Env
+ import System.Exit
+-import System.Directory
++import System.Directory hiding (getFileSize)
+ import System.IO.Unsafe
diff --git a/app-forensics/quickfuzz/files/quickfuzz-0.1_p20160920-ghc-8.0.2_rc1.patch b/app-forensics/quickfuzz/files/quickfuzz-0.1_p20160920-ghc-8.0.2_rc1.patch
new file mode 100644 (file)
index 0000000..0e8abbd
--- /dev/null
@@ -0,0 +1,8 @@
+diff --git a/src/Midi.hs b/src/Midi.hs
+index 2b7a359..8c4eacc 100644
+--- a/src/Midi.hs
++++ b/src/Midi.hs
+@@ -1,2 +1,2 @@
+-{-# LANGUAGE TemplateHaskell, FlexibleInstances#-}
++{-# LANGUAGE TemplateHaskell, FlexibleInstances, OverlappingInstances #-}
index a32bca2ee673a853972487427e1e2688530b0e12..a4e592300bab7f6c07de04efba2feeb4fff0b63b 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -96,6 +96,11 @@ DEPEND="${RDEPEND}
        >=dev-haskell/cabal-1.18.1.3
 "
 
+PATCHES=(
+       "${FILESDIR}"/${P}-ghc-8.0.2_rc1.patch
+       "${FILESDIR}"/${P}-directory-1.3.patch
+)
+
 # $1 - target tarball name (not including extension)
 make_snapshot() {
        ln -s "${S}" "${WORKDIR}"/"$1" || die