net-nds/ypserv: use #!/sbin/openrc-run instead of #!/sbin/runscript
authorAustin English <wizardedit@gentoo.org>
Tue, 3 May 2016 00:01:38 +0000 (19:01 -0500)
committerAustin English <wizardedit@gentoo.org>
Tue, 3 May 2016 00:01:38 +0000 (19:01 -0500)
Gentoo-Bug: https://bugs.gentoo.org/573846

Package-Manager: portage-2.2.26

net-nds/ypserv/files/rpc.yppasswdd-r1
net-nds/ypserv/files/rpc.ypxfrd-2.23
net-nds/ypserv/files/ypserv
net-nds/ypserv/ypserv-2.26-r1.ebuild [new file with mode: 0644]

index 7e7c36a3b837f2be5d22a19a86858670544e86bd..2ed17367e8a8ad38f6e90e7e26dc0dfada6825b8 100644 (file)
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
index ae1f92e1b3d401b7fd82ebb40a53ff447d9264b3..4778a1414d27db5d10acc340640a9b0b5b52fc71 100644 (file)
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2011 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
index a0dd95c6b217ae34c6a15565f59b4b4e63f4b52d..3a4c6c077de549234cd095118d5f4b0ad52122dd 100644 (file)
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
diff --git a/net-nds/ypserv/ypserv-2.26-r1.ebuild b/net-nds/ypserv/ypserv-2.26-r1.ebuild
new file mode 100644 (file)
index 0000000..d315581
--- /dev/null
@@ -0,0 +1,79 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit autotools
+
+DESCRIPTION="Network Information Service server"
+HOMEPAGE="http://www.linux-nis.org/nis/"
+SRC_URI="mirror://kernel/linux/utils/net/NIS/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="slp"
+
+DEPEND=">=sys-libs/gdbm-1.8.0
+        slp? ( net-libs/openslp )"
+RDEPEND="${DEPEND}
+        || ( net-nds/rpcbind net-nds/portmap )"
+
+src_prepare() {
+       # The configure script does not provide a command-line flag to control usage
+       # of slp. Use a brutal method in case we need to disable it.
+       if ! use slp; then
+               sed -i -e 's/USE_SLP=1/USE_SLP=0/g' configure.in || die
+               eautoreconf
+       fi
+
+       default
+}
+
+src_install() {
+       default
+       dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+
+       insinto /etc
+       doins etc/ypserv.conf etc/netgroup etc/netmasks
+       insinto /var/yp
+       newins etc/securenets securenets.default
+
+       newconfd "${FILESDIR}/ypserv.confd" ypserv
+       newconfd "${FILESDIR}/rpc.yppasswdd.confd" rpc.yppasswdd
+       newconfd "${FILESDIR}/rpc.ypxfrd.confd" rpc.ypxfrd
+
+       newinitd "${FILESDIR}/ypserv" ypserv
+       newinitd "${FILESDIR}/rpc.yppasswdd-r1" rpc.yppasswdd
+       newinitd "${FILESDIR}/rpc.ypxfrd-2.23" rpc.ypxfrd
+
+       echo "CONFIG_PROTECT=\"/var/yp/Makefile\"" > "${T}"/10ypserv
+       doenvd "${T}"/10ypserv
+}
+
+pkg_preinst() {
+       # This ebuilds installs an env file which CONFIG_PROTECTs /var/yp/Makefile,
+       # but if the user is migrating from older ypserv, this won't take effect
+       # immediately. Keep the older setup with Makefile.dist file and ask the user
+       # to migrate.
+       if [ -f "${ROOT}/var/yp/Makefile.dist" ]; then
+               mv "${D}/var/yp/Makefile" "${D}/var/yp/Makefile.dist" \
+                       || die "mv failed"
+               cp "${ROOT}/var/yp/Makefile" "${D}/var/yp/Makefile" \
+                       || die "cp failed"
+               elog "Please remove ${ROOT}/var/yp/Makefile.dist after making sure that"
+               elog "${ROOT}/var/yp/Makefile looks fine to you. It is now"
+               elog "CONFIG_PROTECTed, so further changes should be managed with"
+               elog "usual config management tools like etc-update or dispatch-conf."
+       fi
+}
+
+pkg_postinst() {
+       einfo "To complete setup, you will need to edit /var/yp/securenets,"
+       einfo "/etc/conf.d/ypserv, /etc/ypserv.conf, /etc/conf.d/rpc.yppasswdd"
+       einfo "and possibly /var/yp/Makefile."
+
+       einfo "To start the services at boot, you need to enable ypserv and optionally"
+       einfo "the rpc.yppasswdd and/or rpc.ypxfrd services"
+}