kde-apps/step: Add USE=nls and missing DEPEND
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 22 Apr 2017 14:25:51 +0000 (16:25 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 22 Apr 2017 14:32:07 +0000 (16:32 +0200)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

kde-apps/step/step-17.04.0.ebuild

index f1c15a5a9ddc8e85a77930f6d5e01f41152213ea..c121e41b44edd0e38933e850b62f54cf955896af 100644 (file)
@@ -10,9 +10,9 @@ inherit kde5
 DESCRIPTION="Interactive physics simulator"
 HOMEPAGE="https://edu.kde.org/step"
 KEYWORDS="~amd64 ~x86"
-IUSE="+gsl +qalculate"
+IUSE="+gsl nls +qalculate"
 
-DEPEND="
+RDEPEND="
        $(add_frameworks_dep kcompletion)
        $(add_frameworks_dep kconfig)
        $(add_frameworks_dep kconfigwidgets)
@@ -42,7 +42,9 @@ DEPEND="
        gsl? ( sci-libs/gsl:= )
        qalculate? ( >=sci-libs/libqalculate-0.9.5:= )
 "
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+       nls? ( $(add_qt_dep linguist-tools) )
+"
 
 src_prepare() {
        kde5_src_prepare