Bug #230245 - Pass the correct directory when calling `snv list` and
authorZac Medico <zmedico@gentoo.org>
Mon, 30 Jun 2008 21:51:19 +0000 (21:51 -0000)
committerZac Medico <zmedico@gentoo.org>
Mon, 30 Jun 2008 21:51:19 +0000 (21:51 -0000)
`svn status` since repoman supports category-level and repo-level
commits.

svn path=/main/trunk/; revision=10858

bin/repoman

index 51c2ae2d7ac6c709f799a441007abbb06f9722e8..55a8a301f339e82280294b32b26f872f4b5019bf 100755 (executable)
@@ -872,7 +872,7 @@ for x in scanlist:
                        if vcs == "cvs":
                                myf=open(checkdir+"/CVS/Entries","r")
                        if vcs == "svn":
-                               myf=os.popen("svn list")
+                               myf = os.popen("svn list " + checkdir)
                        myl=myf.readlines()     
                        myf.close()
                        for l in myl:
@@ -891,7 +891,7 @@ for x in scanlist:
                                        if l[-7:] == ".ebuild":
                                                eadded.append(l[:-7])
                        if vcs == "svn":
-                               myf=os.popen("svn status")
+                               myf = os.popen("svn status " + checkdir)
                                myl=myf.readlines()
                                myf.close()
                                for l in myl: