dev-perl/Crypt-IDEA: Fix description re bug #694952
authorKent Fredric <kentnl@gentoo.org>
Tue, 24 Sep 2019 02:00:25 +0000 (14:00 +1200)
committerKent Fredric <kentnl@gentoo.org>
Tue, 24 Sep 2019 03:40:55 +0000 (15:40 +1200)
- EAPI7-ify. ( Please tell me if I'm using DEPEND vs BDEPEND wrong,
 the dev-manual is exceedingly unclear on what I'm supposed to do with
 this )
- Fix incorrect description as per bug #694952
- Clarify dependencies

Bug: https://bugs.gentoo.org/694952
Package-Manager: Portage-2.3.75, Repoman-2.3.16
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/Crypt-IDEA/Crypt-IDEA-1.100.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-perl/Crypt-IDEA/Crypt-IDEA-1.100.0-r1.ebuild b/dev-perl/Crypt-IDEA/Crypt-IDEA-1.100.0-r1.ebuild
new file mode 100644 (file)
index 0000000..4a8e0cc
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DPARIS
+DIST_VERSION=1.10
+inherit perl-module
+
+DESCRIPTION="An implementation of the IDEA symmetric-key block cipher"
+
+LICENSE="Crypt-IDEA"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND=""
+BDEPEND="virtual/perl-ExtUtils-MakeMaker
+       test? (
+               virtual/perl-Test-Simple
+       )
+"