sci-mathematics/z3: workaround configure failure on non-ASCII
authorSergei Trofimovich <slyfox@gentoo.org>
Wed, 15 Feb 2017 23:00:44 +0000 (23:00 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Thu, 16 Feb 2017 10:21:42 +0000 (10:21 +0000)
On my LANG=ru_RU.UTF-8 locale configure step fails as:
    File "scripts/mk_make.py", line 21, in <module>
    ...
    UnicodeEncodeError: 'ascii' codec can't encode characters in position 80-82: ordinal not in range(128)

Workaround configure breakage by stabilising locale.

Package-Manager: Portage-2.3.3, Repoman-2.3.1

sci-mathematics/z3/z3-4.5.0.ebuild

index 30eea151404e2a673eee7076f48aa4e1596039b5..0cd4becd54855bfc3140d8f4e27016af2567d990 100644 (file)
@@ -79,8 +79,13 @@ src_configure() {
                $(usex python --python "") \
                $(usex java --java "")
        elog ./configure "$@"
-       ./configure "$@" || die
-       ${EPYTHON} scripts/mk_make.py || die
+       # LANG=C to force external tools to output ascii text only
+       # otherwise configure crashes as:
+       #    File "scripts/mk_make.py", line 21, in <module>
+       #    UnicodeEncodeError: 'ascii' codec can't encode characters in position 80-82: ordinal not in range(128)
+       LANG=C ./configure "$@" || die
+       elog ${EPYTHON} scripts/mk_make.py "$@"
+       LANG=C ${EPYTHON} scripts/mk_make.py || die
 }
 
 src_compile() {