dev-python/jaraco-functools: Use distutils_enable_sphinx
authorMichał Górny <mgorny@gentoo.org>
Mon, 25 Nov 2019 12:25:03 +0000 (13:25 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 25 Nov 2019 12:35:10 +0000 (13:35 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/jaraco-functools/jaraco-functools-2.0-r1.ebuild

index 348372445e08c60ea9597b1042aeed14750e7605..b90ba6298d7549ab0692676d6803f8c2512f0f51 100644 (file)
@@ -11,11 +11,13 @@ MY_PN="${PN/-/.}"
 DESCRIPTION="Additional functions used by other projects by developer jaraco"
 HOMEPAGE="https://github.com/jaraco/jaraco.functools"
 SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
 
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="doc test"
+IUSE="test"
+RESTRICT="!test? ( test )"
 
 RDEPEND="
        >=dev-python/namespace-jaraco-2[${PYTHON_USEDEP}]
@@ -23,13 +25,6 @@ RDEPEND="
        $(python_gen_cond_dep 'dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]' python2_7)
 "
 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? (
-               $(python_gen_any_dep '
-                       >=dev-python/jaraco-packaging-3.2[${PYTHON_USEDEP}]
-                       >=dev-python/rst-linker-1.9[${PYTHON_USEDEP}]
-                       dev-python/sphinx[${PYTHON_USEDEP}]'
-               )
-       )
        test? (
                ${RDEPEND}
                >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
@@ -39,19 +34,11 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
        )
 "
 
-RESTRICT="!test? ( test )"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
 PATCHES=( "${FILESDIR}/${P}-fix-py37-tests.patch" )
 
-python_check_deps() {
-       use doc || return 0
-
-       has_version ">=dev-python/jaraco-packaging-3.2[${PYTHON_USEDEP}]" && \
-               has_version ">=dev-python/rst-linker-1.9[${PYTHON_USEDEP}]" && \
-               has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
-}
+distutils_enable_sphinx docs \
+       ">=dev-python/jaraco-packaging-3.2" \
+       ">=dev-python/rst-linker-1.9"
 
 python_prepare_all() {
        # avoid a setuptools_scm dependency
@@ -62,14 +49,6 @@ python_prepare_all() {
        distutils-r1_python_prepare_all
 }
 
-python_compile_all() {
-       if use doc; then
-               cd docs || die
-               sphinx-build . _build/html || die
-               HTML_DOCS=( docs/_build/html/. )
-       fi
-}
-
 python_test() {
        # Override pytest options to skip flake8
        PYTHONPATH=. pytest -vv --override-ini="addopts=--doctest-modules" \