dev-python/pyregion: remove last-rited pkg
authorMikle Kolyada <zlogene@gentoo.org>
Sat, 28 Dec 2019 16:45:48 +0000 (19:45 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Sat, 28 Dec 2019 16:45:48 +0000 (19:45 +0300)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
dev-python/pyregion/Manifest [deleted file]
dev-python/pyregion/metadata.xml [deleted file]
dev-python/pyregion/pyregion-1.1.4.ebuild [deleted file]
dev-python/pyregion/pyregion-1.2.ebuild [deleted file]

diff --git a/dev-python/pyregion/Manifest b/dev-python/pyregion/Manifest
deleted file mode 100644 (file)
index d91444d..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST pyregion-1.1.4.tar.gz 99454 BLAKE2B e8e58364d825261baa9a706e02c0d2c57fab3b0fbdc18da1bbb07015f308c856795802af0ed8a09ecfac30600c0fa7fffaa824d5c330f45377208248d439b139 SHA512 572a10593dc93f64ad6fd1d7a8f19582df04309b88a73fb41e3b4c71036d61c3857114cc01025e581ddd3a63af92fabb5375c1ee8fe487f83da2780569954236
-DIST pyregion-1.2.tar.gz 1133496 BLAKE2B eea77b0c015b96aa277aa971e890db71cae2e5de112fa34898df8a80fdd48bbc7f13b3f298582d51bcead609c62e90d3e5c049bda37603e8ae1d655cb4f618c1 SHA512 80f851ecc8ec60a287b11b558fab920da7565c3574b0e6e977b8c8e3f40951f0407b27cc1c24e0d9d864f9b853b03053e9fae3ee81a32ab36078f2c8ce6334b9
diff --git a/dev-python/pyregion/metadata.xml b/dev-python/pyregion/metadata.xml
deleted file mode 100644 (file)
index 255624c..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
-  <email>sci-astronomy@gentoo.org</email>
-  <name>Gentoo Astronomy Project</name>
-</maintainer>
-<longdescription lang="en">
-  pyregion is a python module to parse ds9 region files. It also
-  support ciao region files, and can draw regions using matplotlib.
-</longdescription>
-<upstream>
-  <remote-id type="pypi">pyregion</remote-id>
-</upstream>
-</pkgmetadata>
diff --git a/dev-python/pyregion/pyregion-1.1.4.ebuild b/dev-python/pyregion/pyregion-1.1.4.ebuild
deleted file mode 100644 (file)
index fe132cb..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_5} )
-inherit distutils-r1
-
-DESCRIPTION="Python module to parse ds9 region file"
-HOMEPAGE="http://pyregion.readthedocs.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-LICENSE="MIT"
-
-IUSE="examples"
-RDEPEND="
-       dev-python/numpy[${PYTHON_USEDEP}]
-       dev-python/pyparsing[${PYTHON_USEDEP}]"
-DEPEND="${DEPEND}
-       || ( dev-python/cython[${PYTHON_USEDEP}]
-                dev-python/pyrex[${PYTHON_USEDEP}] )"
-
-python_install_all() {
-       distutils-r1_python_install_all
-       if use examples; then
-               insinto /usr/share/doc/${PF}
-               doins -r examples
-       fi
-}
diff --git a/dev-python/pyregion/pyregion-1.2.ebuild b/dev-python/pyregion/pyregion-1.2.ebuild
deleted file mode 100644 (file)
index d7973d3..0000000
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-inherit distutils-r1 virtualx xdg-utils
-
-DESCRIPTION="Python module to parse ds9 region file"
-HOMEPAGE="http://pyregion.readthedocs.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-LICENSE="MIT"
-
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-RDEPEND="
-       dev-python/astropy[${PYTHON_USEDEP}]
-       dev-python/numpy[${PYTHON_USEDEP}]
-       dev-python/pyparsing[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       dev-python/astropy-helpers[${PYTHON_USEDEP}]
-       dev-python/cython[${PYTHON_USEDEP}]
-       doc? (
-               dev-python/sphinx[${PYTHON_USEDEP}]
-               dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
-               dev-python/wcsaxes[${PYTHON_USEDEP}] )
-       test? (
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/matplotlib[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
-       # use astropy-helpers from system
-       sed -i -e '/auto_use/s/True/False/' setup.cfg || die
-       xdg_environment_reset
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       if use doc; then
-               python_setup
-               VARTEXFONTS="${T}"/fonts \
-                       MPLCONFIGDIR="${BUILD_DIR}" \
-                       PYTHONPATH="${BUILD_DIR}"/lib \
-                       esetup.py build_sphinx --no-intersphinx
-       fi
-}
-
-python_test() {
-       virtx esetup.py test
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-       distutils-r1_python_install_all
-       if use examples; then
-               insinto /usr/share/doc/${PF}
-               doins -r examples
-       fi
-}