net-nntp/suck: Version bump, 4.3.4
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>
Tue, 28 Apr 2020 08:26:18 +0000 (11:26 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 28 Apr 2020 08:29:03 +0000 (11:29 +0300)
Closes: https://bugs.gentoo.org/696724
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
net-nntp/suck/Manifest
net-nntp/suck/metadata.xml
net-nntp/suck/suck-4.3.4.ebuild [new file with mode: 0644]

index 108ca28c5e7f3b51aaaae08e59fecd1dba08c773..b155621ede4743f302c7bf28a20728a43f5b4e7e 100644 (file)
@@ -1 +1,2 @@
 DIST suck-4.3.3.tar.gz 153624 BLAKE2B 434bdb21ba37deefcba4c0fa9ec3cdf14bc49e1295533ae3c7fb298f49819113ad05e26b3ca72e20ebdd498b0514155f8d79e7c82e95f423521586de889c2371 SHA512 629ecbd7e8d070fc9c1175be6dd10d49fe71b59b8694f32a81cc2dd5ec46e32d64463d221052922a7e21fcac1c9a330f56399bad7c64fa653d68127cd16dbfdc
+DIST suck-4.3.4.tar.gz 153774 BLAKE2B dc7943af43a305386872995a27b6e2faf34949813960314cbf85c4f2ad1658107480cdf77241394aa031270afc3faab5fbd30ec19559fb3d4d261fd8fa5e3416 SHA512 79892cfce1b569bbd5fb6468a919d77bce82a533c1b70369ab88a2066dc3d4396480b9a56b25e960d6e49cd0f9abad605d841693f086c9d07913798d7ac99730
index 04692a1a2185f1223870f5aa130b12edd77cda89..b5647d42ed7bcf1ed933d4f9d926e0e3b86ddaca 100644 (file)
@@ -1,7 +1,14 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-       <!-- maintainer-needed -->
+       <maintainer type="person">
+               <email>contact@hacktivis.me</email>
+               <name>Haelwenn (lanodan) Monnier</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
        <upstream>
                <remote-id type="github">lazarus-pkgs/suck</remote-id>
        </upstream>
diff --git a/net-nntp/suck/suck-4.3.4.ebuild b/net-nntp/suck/suck-4.3.4.ebuild
new file mode 100644 (file)
index 0000000..6e3a553
--- /dev/null
@@ -0,0 +1,61 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Grab news from a remote NNTP server and feed them to another"
+HOMEPAGE="https://lazarus-pkgs.github.io/lazarus-pkgs/suck.html"
+SRC_URI="https://github.com/lazarus-pkgs/suck/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="perl ssl libressl"
+
+RDEPEND="
+       sys-libs/gdbm:=
+       ssl? (
+               !libressl? ( dev-libs/openssl:0= )
+               libressl? ( dev-libs/libressl:= )
+       )
+"
+DEPEND="${RDEPEND}
+       sys-libs/db
+       perl? ( dev-lang/perl )
+"
+
+src_prepare() {
+       default
+
+       # Fix paths to the locations in Gentoo
+       sed -i \
+               -e 's:/usr/bin/rnews:/usr/$(get_libdir)/news/bin/rnews:' \
+               -e 's:/var/lib/news/history:/var/spool/news/db/history:' \
+               suck_config.h || die "path adaption sed failed"
+
+       eautoreconf
+}
+
+src_configure() {
+       use ssl || sed -i -e 's/^SSL_/#SSL_/' Makefile.in || die "ssl sed failed"
+       use perl || sed -i -e 's/^PERL_/#PERL_/' Makefile.in || die "perl sed failed"
+
+       econf --without-inn-lib --without-inn-include
+}
+
+src_compile() {
+       emake phrases.h
+       emake all lpost
+}
+
+src_install() {
+       dobin lmove lpost rpost suck testhost
+       doman man/*
+       dodoc CHANGELOG CONTENTS README*
+       docinto java
+       dodoc java/*
+       docinto perl
+       dodoc perl/*
+       docinto sample
+       dodoc sample/*
+}