ugh, just fix the patch, dont patch it
authorMike Frysinger <vapier@gentoo.org>
Wed, 21 Jun 2006 20:52:24 +0000 (20:52 +0000)
committerMike Frysinger <vapier@gentoo.org>
Wed, 21 Jun 2006 20:52:24 +0000 (20:52 +0000)
Package-Manager: portage-2.1.1_pre1-r1

sys-apps/pciutils/files/pcimodules-pciutils-2.1.11.diff
sys-apps/pciutils/files/pcimodules-pciutils-2.2.0.patch
sys-apps/pciutils/pciutils-2.1.11-r5.ebuild
sys-apps/pciutils/pciutils-2.2.0-r1.ebuild
sys-apps/pciutils/pciutils-2.2.3.ebuild

index a351a2c66bd1840f997a0fd3411e679cd42e6739..e3023b8a97bfce7b35100a17ba98582b8dd95bb4 100644 (file)
@@ -59,7 +59,7 @@
        /* For cardbus bridges, we need to fetch 64 bytes more to get the full standard header... */
 --- ./pcimodules.c.orig        2003-02-20 23:22:36.000000000 -0800
 +++ ./pcimodules.c     2003-02-20 23:22:36.000000000 -0800
-@@ -0,0 +1,183 @@
+@@ -0,0 +1,182 @@
 +/*
 + *    pcimodules:  Load all kernel modules for PCI device currently
 + *      plugged into any PCI slot.
@@ -78,7 +78,6 @@
 +
 +#include <stdlib.h>
 +#include <stdio.h>
-+#include <malloc.h>
 +#include <string.h>
 +#include <unistd.h>
 +#include <sys/utsname.h>
index 584bfde6e14b43c83d751d8175b35b2026543a6d..3b778cdeb51fca543a08c526fe0b8c24f4aade7b 100644 (file)
@@ -58,7 +58,7 @@
        cp ~/tree/pciids/pci.ids pci.ids
 --- pciutils-2.2.0/pcimodules.c
 +++ pciutils-dsd/pcimodules.c
-@@ -0,0 +1,183 @@
+@@ -0,0 +1,182 @@
 +/*
 + *    pcimodules:  Load all kernel modules for PCI device currently
 + *      plugged into any PCI slot.
@@ -77,7 +77,6 @@
 +
 +#include <stdlib.h>
 +#include <stdio.h>
-+#include <malloc.h>
 +#include <string.h>
 +#include <unistd.h>
 +#include <sys/utsname.h>
index 5e2fb18408854a08ab6eda95341d824673801fae..740456bfbc4683f50ee843e50a53e100f5e02d1b 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.1.11-r5.ebuild,v 1.11 2005/11/11 19:46:34 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.1.11-r5.ebuild,v 1.12 2006/06/21 20:52:24 vapier Exp $
 
 inherit eutils flag-o-matic toolchain-funcs
 
@@ -26,7 +26,6 @@ src_unpack() {
        epatch "${FILESDIR}"/${P}-gentoo-paths.patch
        epatch "${FILESDIR}"/${PV}-scan.patch #from fedora
        epatch "${FILESDIR}"/${P}-bsd.patch #103241
-       epatch "${FILESDIR}"/${P}-malloc.patch
 
        # Unconditionally use -fPIC for libs (#55238)
        # Make sure we respect $AR / $RANLIB / $CFLAGS
index 0e2dd5526421920a86d125619c7c74f317cb1630..38e7277efc7bd6e11775b3ca658638320b4d4c8a 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.2.0-r1.ebuild,v 1.14 2006/04/18 17:05:48 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.2.0-r1.ebuild,v 1.15 2006/06/21 20:52:24 vapier Exp $
 
 inherit eutils flag-o-matic toolchain-funcs
 
@@ -23,7 +23,6 @@ src_unpack() {
 
        epatch "${FILESDIR}"/pcimodules-${P}.patch
        epatch "${FILESDIR}"/${P}-shared-lib.patch
-       epatch "${FILESDIR}"/${PN}-2.1.11-malloc.patch
 
        # Set Gentoo paths
        # and do not strip (breaks cross-compile), portage handles stripping
index 188c58d604be810dd38d105275f227a9f67b6ddb..365c420703dfbce3e540606fd5fbaecf839e0193 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.2.3.ebuild,v 1.1 2006/06/08 10:30:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.2.3.ebuild,v 1.2 2006/06/21 20:52:24 vapier Exp $
 
 inherit eutils flag-o-matic toolchain-funcs
 
@@ -23,7 +23,6 @@ src_unpack() {
 
        epatch "${FILESDIR}"/pcimodules-${PN}-2.2.0.patch
        epatch "${FILESDIR}"/${PN}-2.2.0-shared-lib.patch
-       epatch "${FILESDIR}"/${PN}-2.1.11-malloc.patch
 
        # Set Gentoo paths
        # and do not strip (breaks cross-compile), portage handles stripping